> I downloaded the SVN trunk of ICS and tried to compile the first 
> package (IcsCommonDXE5Run.bpl) with XE5. Both Windows targets 
> compile fine, however the OSX target does not. It tries to 
> compile OverbyteIcsCryptUiApi:

That unit supports Windows APIs, so fails on MacOS.  It allows access
to the Windows SSL certificate store instead of applications providing
their own root store (which is a pain to maintain).  

I added it to the IcsCommon packages two years ago for V8.18, another
user tested MacOS in June and found some issues all of which were fixed
then, but not with OverbyteIcsCryptUiApi.  

Guess I should have put these Windows only units in IcsVCL packages,
but that means dozens of files to update so I've used conditions to
make sure Windows stuff only builds on windows. 

In SVN now, but not yet in the overnight zip.  Can you please confirm
V8.50 builds again on MacOS?    

Angus

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to