Hi Elliot!

On Fri, Jul 16, 2010 at 4:38 AM, Elliot Murphy <ell...@canonical.com> wrote:
> Hi!
>
> https://bugs.edge.launchpad.net/txamqp/+bug/605699 is blocking
> packaging for Fedora, and it also blocks me from packaging txamqp for
> Debian/Ubuntu.
>
> Could we have a new release uploaded to launchpad and pypi with the
> license file included in the tarball?

Sure, committed. Will upload it to pypi today.

> One more thing, the versions of the spec files that are included in
> trunk and the 0.3 release of txamqp have serious licensing problems
> that will prevent txamqp from being included in Debian/Ubuntu. The
> AMQP working group has acknowledged these problems and provided
> versions of the spec files that do not have the licensing problems.

I merged 538999-queue-unbind-xml into the trunk, which incorporates
the BSD-licensed version of the AMQP 0.8 spec (plus a small change to
add support for queue.unbind). I'll upload the one for AMQP 0.9 too.

> Also, I see there are also 6 branches pending on the active reviews
> page, all of which have been sitting for a couple of months:
> https://code.edge.launchpad.net/~txamqpteam/txamqp/trunk/+activereviews
> Is this project becoming abandoned? It seems like branches should be
> reviewed and merged or rejected, sitting in limbo for a long time is a
> warning sign.

Some of them were already merged or rejected, but I didn't marked them
as such. I know it's no excuse, but things have been a bit stressful
in Fluidinfoland in the last couple of months. Anyway, thanks a lot
for the wake up call :-)

Cheers.

_______________________________________________
Mailing list: https://launchpad.net/~txamqp-dev
Post to     : txamqp-dev@lists.launchpad.net
Unsubscribe : https://launchpad.net/~txamqp-dev
More help   : https://help.launchpad.net/ListHelp

Reply via email to