Hi all,

I one website with DE and FR language and i'd like to install 5 domains 4 for the "DE" 
lang and 4 for the "FR" lang, here the code i make for it in realUrl configuration:

'mysite.com' => [
                'preVars' => [
                        [
                                'GETvar' => 'L',
                                'valueMap' => [
                                        'de' => 0,
                                        'fr' => 1,
                                ],
                                'noMatch' => 'bypass',
                        ],
                ],
                // other options follow
        ],
        'mysite.de' => 'mysite.com',
        'mysite1.de' => 'mysite.com',
        'mysite2.de' => 'mysite.com',
        'mysite3.de' => 'mysite.com',
        'mysite.ch' => 'mysite.com',
        'mysite2.ch' => 'mysite.com',
        'mysite.fr' => 'mysite.com',
        'mysite2.fr' => 'mysite.com',
 // DECODE
   '_DOMAINS' => [
                'encode' => [
                        [
                                'GETvar' => 'L',
                                'value' => '0',
                                'urlPrepend' => 'https://mysite.com/',
                                'useConfiguration' => 'mysite.com',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '0',
                                'urlPrepend' => 'https://mysite1.com/',
                                'useConfiguration' => 'mysite1.com',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '0',
                                'urlPrepend' => 'https://mysite2.com/',
                                'useConfiguration' => 'mysite2.com',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '0',
                                'urlPrepend' => 'https://mysite3.com/',
                                'useConfiguration' => 'mysite3.com',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '1',
                                'urlPrepend' => 'https://mysite.ch/',
                                'useConfiguration' => 'mysite.ch',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '1',
                                'urlPrepend' => 'https://mysite2.ch/',
                                'useConfiguration' => 'mysite2.ch',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '1',
                                'urlPrepend' => 'https://mysite.fr/',
                                'useConfiguration' => 'mysite.fr',
                        ],
                        [
                                'GETvar' => 'L',
                                'value' => '1',
                                'urlPrepend' => 'https://mysite2.fr/',
                                'useConfiguration' => 'mysite2.fr',
                        ],
                ],
   ],

The *.com and *.de are in German Lang, the .ch and .fr are in French lang, can 
anyone help me please with this ?

_______________________________________________
TYPO3-english mailing list
TYPO3-english@lists.typo3.org
http://lists.typo3.org/cgi-bin/mailman/listinfo/typo3-english

Reply via email to