Stefan Roese wrote:
>>> @@ -243,9 +243,11 @@ reset:
>>>     mtc0    zero, CP0_COUNT
>>>     mtc0    zero, CP0_COMPARE
>>>
>>> +#if !defined(CONFIG_SKIP_LOWLEVEL_INIT)
>>>     /* CONFIG0 register */
>>>     li      t0, CONF_CM_UNCACHED
>>>     mtc0    t0, CP0_CONFIG
>>> +#endif /* !CONFIG_SKIP_LOWLEVEL_INIT */
>>>
>>>     /* Initialize $gp.
>>>      */
>> It might be preferable to remove the /* CONFIG_SKIP_LOWLEVEL_INIT */
>> comment for better readability, IMHO.
> 
> Hmmm. I usually prefer to add those comments to the #else and #endif since it 
> makes the code better readable.

We have just 3 lines within #if-endif, then it looks better without the
latter comment in this case, IMHO.

> Especially when the chunks of code in-between 
> gets bigger. So I would prefer to keep this comment. OK?

Fully agreed, of course.  Thanks for the explanation, and it's up to
you.

>> - Could we separate this flush_cache patch from this patch?
> 
> OK, will do.
> 
>> - Please use save register, s[0-7], instead of t7, since t7 register
>>   might be overwritten with another value in flush_cache().
>>   Furthermore, in this case, a2 should be saved as well.
> 
> I'm still new to MIPS so thanks for your suggestions. I'll try to provide a 
> fixed up patch today.
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to