Hi Sandy,

On 09/20/2016 11:04 PM, Sandy Patterson wrote:
I can confirm that this boots on rock2 with current master branch. 9b1b6d42256a4c2e59c803afdbf90d39371e61ba



Thanks for your test.

It doesn't boot for me using rock2 on v2016.09 tag. I get:
U-Boot SPL 2016.09-00002-g690a8a3 (Sep 20 2016 - 10:47:44)
Trying to boot from MMC1

It continues to detect 2GB of ram. on master.

I get nervous with these memory changes. We found that some memory parameters persisted through to linux and had the ability to cause instability. I don't run have linux setup right now on my rock2, so I can't test that.


parameters changes from dts to auto-detect including those I removed from dts and ddrconfig, stride, they should be the same as without my patch, which means my patch suppose to not change any parameter for DDR other than how we get those parameters.

I also wanted to test that the parameters detected via the new routine matched those removed from the dts file. I tried enabling DEBUG but that somehow caused no console output anymore (on master). I'm not sure what's going on. I also tried doing some printfs but they had the same effect. It looks like somehow the console init has moved and maybe isn't setup yet.

I think you need to define EARLY_DEBUG in arch/arm/mach-rockchip/rk3288-board-spl.c and then using printf or debug with DEBUG macro enable.

Thanks,
- Kever

Sandy





_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot

Reply via email to