Hi Jagan

There is a git log for that configuration file. I have the impression
that is done in two steps

Michael

On Tue, Mar 6, 2018 at 3:16 PM, Stefano Babic <sba...@denx.de> wrote:
> On 06/03/2018 15:12, Jagan Teki wrote:
>> On Tue, Mar 6, 2018 at 6:46 PM, Fabio Estevam <feste...@gmail.com> wrote:
>>> Hi Jagan,
>>>
>>> On Tue, Mar 6, 2018 at 9:25 AM, Jagan Teki <jagannadh.t...@gmail.com> wrote:
>>>> Hi,
>>>>
>>>> U-Boot SPL 2018.03-rc3-00111-g0cb2734156-dirty (Mar 06 2018 - 17:19:36 
>>>> +0530)
>>>> Trying to boot from USB SDP
>>>> SDP: initialize...
>>>> SDP: handle requests...
>>>>
>>>> and SPL reenumerated USB VID/PID as
>>>> [24774.255201] usb 1-2: new high-speed USB device number 101 using xhci_hcd
>>>> [24774.425174] usb 1-2: New USB device found, idVendor=0525, idProduct=b4a4
>>>> [24774.425181] usb 1-2: New USB device strings: Mfr=1, Product=2, 
>>>> SerialNumber=0
>>>> [24774.425185] usb 1-2: Product: USB download gadget
>>>> [24774.425189] usb 1-2: Manufacturer: FSL
>>>> [24774.433598] hid-generic 0003:0525:B4A4.005C: hiddev97,hidraw2: USB
>>>> HID v1.10 Device [FSL USB download gadget]
>>>>
>>>> Now I've launched u-boot-dtb.img
>>>>
>>>> $ imx_usb u-boot-dtb.img
>>>> ...
>>>> vid=0x0525 pid=0xb4a4 file_name=mx6_usb_sdp_spl.conf
>>>> config file <.//mx6_usb_sdp_spl.conf>
>>>> parse .//mx6_usb_sdp_spl.conf
>>>> Trying to open device vid=0x0525 pid=0xb4a4
>>>> Interface 0 claimed
>>>> HAB security state: development mode (0x56787856)
>>>> == work item
>>>> filename /work/code/u-boot/u-boot-dtb.img
>>>> load_size 0 bytes
>>>> load_addr 0x00000000
>>>> dcd 1
>>>> clear_dcd 0
>>>> plug 1
>>>> jump_mode 2
>>>> jump_addr 0x00000000
>>>> == end work item
>>>>
>>>> unknown load address
>>>> DoIRomDownload failed, err=-3
>>>> HAB security state: development mode (0x56787856)
>>>>
>>>> Here is mx6_usb_sdp_spl.conf file
>>>>    mx6_spl_sdp
>>>>    hid,uboot_header,1024,0x910000,0x10000000,512M,0x00900000,0x40000
>>>>
>>>> Look like the u-boot-dtb.img has FIT header and imx_usb can't process
>>>> the same, any help?
>>>
>>> Is this a regression? If so, are you able to run a 'git bisect'?
>>
>> I don't think it's regression, I'm guessing this is first test with
>> u-boot-dtb.img or did you tested the similar image type?
>>
>
> Never tested with u-boot-dtb.img, it worked fine with u-boot.img
>
> Best regards,
> Stefano
>
> --
> =====================================================================
> DENX Software Engineering GmbH,      Managing Director: Wolfgang Denk
> HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: +49-8142-66989-53 Fax: +49-8142-66989-80 Email: sba...@denx.de
> =====================================================================
> _______________________________________________
> U-Boot mailing list
> U-Boot@lists.denx.de
> https://lists.denx.de/listinfo/u-boot



-- 
| Michael Nazzareno Trimarchi                     Amarula Solutions BV |
| COO  -  Founder                                      Cruquiuskade 47 |
| +31(0)851119172                                 Amsterdam 1018 AM NL |
|                  [`as] http://www.amarulasolutions.com               |
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to