On 04/10/2018 02:25 PM, Marek Vasut wrote:
> On 04/10/2018 08:56 PM, Dinh Nguyen wrote:
>>
>>
>> On 04/10/2018 01:29 PM, Marek Vasut wrote:
>>> On 04/10/2018 08:28 PM, Dinh Nguyen wrote:
>>>> Hi,
>>>>
>>>> I'm seeking advice with an observation that I'm seeing on the Cyclone5
>>>> devkit/sockit.
>>>>
>>>> I'm working with U-Boot version v2018.05-rc1. Building the
>>>> u-boot-with-spl.sfp, then writing the sfp file to the 0xa2 partition on
>>>> the SD card, does not boot, all I get is this:
>>>>
>>>> U-Boot SPL 2018.05-rc1 (Apr 10 2018 - 13:03:48 -0500)
>>>>
>>>> U-Boot SPL 2018.05-rc1 (Apr 10 2018 - 13:03:48 -0500)
>>>>
>>>> U-Boot SPL 2018.05-rc1 (Apr 10 2018 - 13:03:48 -0500)
>>>>
>>>>
>>>> This issue doesn't happen at all on the DE0 Nano SoC board. I compared
>>>> the defconfig and came across this. If I remove these config options in
>>>> the socfpga_sockit_defconfig, then SPL -> U-Boot works fine.
>>>>
>>>> -CONFIG_SPI_FLASH_MACRONIX=y
>>>> -CONFIG_SPI_FLASH_SPANSION=y
>>>> -CONFIG_SPI_FLASH_STMICRO=y
>>>>
>>>> I'll continue to debug of course, but was wondering if anyone might have
>>>> a better idea as to what could be happening, I'd appreciate the insight.
>>>
>>> Check the size of the SPL , could it be too big ?
>>>
>>
>> That's a good thought...it could be. The size of the default
>> u-boot-spl-dtb.bin is 58048, removing the SPI, brings that down to
>> 55616, that's smaller than the 64k of OCRAM for SPL?
> 
> Right, I think there's something about those last few kiB OR it's the
> stack that's overwriting piece of U-Boot or malloc area or something.
> How did it grow so big anyway ?
> 

Ah, looks like SYS_MALLOC_F_LEN is set to 8k, thus, we're over the 64k
limit. Setting SYS_MALLOC_F_LEN to 4k makes it work again. I'm not sure
how the SPL grew so big.

Dinh
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to