On 04/26/2018 10:47 PM, Bryan O'Donoghue wrote:
> Compiling the f_mass_storage driver for an x86 target results in a
> compilation error as set_bit and clear_bit are provided by bitops.h
> 
> The local version of set_bit and clear_bit are doing some IP-block specific
> bit-twiddling so we don't actually want to accidentally pick up the
> bitops.h version of set_bit and clear bit.
> 
> This patch renames to _set_bit() and _clear_bit() respectively to avoid the
> namespace collision.
> 
> Signed-off-by: Bryan O'Donoghue <pure.lo...@nexus-software.ie>
> Cc: Lukasz Majewski <lu...@denx.de>
> Cc: Marek Vasut <ma...@denx.de>
> ---
>  drivers/usb/gadget/f_mass_storage.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/usb/gadget/f_mass_storage.c 
> b/drivers/usb/gadget/f_mass_storage.c
> index 1ecb92ac6b..524c43419f 100644
> --- a/drivers/usb/gadget/f_mass_storage.c
> +++ b/drivers/usb/gadget/f_mass_storage.c
> @@ -283,7 +283,7 @@ static const char fsg_string_interface[] = "Mass Storage";
>  struct kref {int x; };
>  struct completion {int x; };
>  
> -inline void set_bit(int nr, volatile void *addr)
> +inline void _set_bit(int nr, volatile void *addr)

Do not name functions with _ prefix. Also, I think the suggestion from
Lukasz was better.

-- 
Best regards,
Marek Vasut
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to