On Tue, Jul 10, 2018 at 9:37 PM, Belisko Marek <marek.beli...@gmail.com> wrote:
> Hello,
>
> I'm trying to use u-boot on CM3 (which contains eMMC) to boot kernel.
> I'm using u-boot 2018.05 and it can start fine like:
> U-Boot 2018.05 (Jul 10 2018 - 20:32:05 +0000)
>
> DRAM:  948 MiB
> RPI Compute Module 3 (0xa220a0)
> MMC:   sdhci@7e300000: 0
> Loading Environment from FAT... unable to select a mode
> ** No partition table - mmc 0 **
> Failed (-5)
> In:    serial
> Out:   vidconsole
> Err:   vidconsole
> Net:   No ethernet found.
> starting USB...
> USB0:   scanning bus 0 for devices... 1 USB Device(s) found
>        scanning usb for storage devices... 0 Storage Device(s) found
> Hit any key to stop autoboot:  0
> U-Boot>
> U-Boot>
> U-Boot>
> U-Boot> mmc info
> Device: sdhci@7e300000
> Manufacturer ID: 15
> OEM: 100
> Name: 4FPD3
> Bus Speed: 52000000
> Mode : MMC legacy
> Rd Block Len: 512
> MMC version 5.0
> High Capacity: Yes
> Capacity: 3.6 GiB
> Bus Width: 1-bit
> Erase Group Size: 512 KiB
> HC WP Group Size: 8 MiB
> User Capacity: 3.6 GiB WRREL
> Boot Capacity: 4 MiB ENH
> RPMB Capacity: 512 KiB ENH
> U-Boot> mmc part
> ## Unknown partition table type 0
> U-Boot> mmc read $loadaddr 0 2
>
> but reading from eMMC fails with:
>
> MMC read: dev # 0, block # 0, count 2 ... 0 blocks read: ERROR
>
> so it looks like eMMC is not properly working with CM3 in this
> version? Any ideas what to check to have it working before I dig to
> debugging session ;). Thanks.

I'm sure there was a patch series explicitly enabling the CM3 and
associated IO board but I don't see it in git or my inbox but maybe my
search fu is off this morning. There is a patch series landing in 4.19
with support for it [1] so I suspect it'll be worthwhile someone
looking at proper support for it in u-boot too.

[1]  http://lists.infradead.org/pipermail/linux-rpi-kernel/2018-July/007651.html
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to