On 2/12/19 11:13 AM, Chee, Tien Fong wrote:
> On Tue, 2019-02-12 at 10:43 +0100, Marek Vasut wrote:
>> On 2/12/19 10:35 AM, Chee, Tien Fong wrote:
>> [...]
>>
>>>
>>>>
>>>> my preference for the fit image would be
>>>>
>>>> ...
>>>> images {
>>>>   fpga@1 {
>>>>    description = "FPGA Periph";
>>>>    ...
>>>>    type = "fpga_periph";
>>>>    ...
>>>>   }
>>>>   fpga@2 {
>>>>    description = "FPGA Core";
>>>>    ...
>>>>    type = "fpga" or
>>>> "fpga_core";
>>> I'm good with "fpga".
>>>>
>>>>    ...
>>>>   }
>>>> };
>>>> configurations {
>>>>   default = "config@1"
>>>>   config@1 {
>>>>       fpga = "fpga@1";  // periph only
>>>>   };
>>>>   config@2 {
>>>>       fpga = "fpga@1", "fpga@2";
>>>>   };
>>>> };
>>>>
>>>> with the expectation that the order of fpga@1 and fpga@2 in confi
>>>> g@2
>>>> is not relevant.  the code should find the fpga_periph type and
>>>> program
>>>> it first.  just my comment, i dont like rellying on the order or
>>>> name.
>>> I can add support for above implementation although this adds more
>>> complexity to the driver.
>> You can have fpga node and e.g. fpga-name node in the configurations
>> section to discern which phandle there is the core and which is the
>> peripheral RBF. Would that work ?
>>
> So something like that?
> 
> ...
> 
> images {
>   fpga-periph@1 {
>       description = "FPGA Periph";
>       ...
>       type = "fpga_periph";

Do we need a new type for the periph/core distinction ?

>       ...
>   }
>   fpga-core@2 {
>       description = "FPGA Core";
>       ...
>       type = "fpga";
>       ...
>   }
> };
> configurations {
>   default = "config@1"
>   config@1 {
>       fpga = "fpga-periph@1";  // periph only
>   };
>   config@2 {
>       fpga = "fpga-periph@1", "fpga-core@2";
>   };
> };
> 
>>>
>>> Marek, are you OK with this implementation?
>> Looks OK to me. Dalon ?
>>
>> [...]


-- 
Best regards,
Marek Vasut
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to