> From: Anthony Davies <anthony.t.davies+ml_ub...@gmail.com>
> Date: Fri, 22 May 2020 10:49:12 +1000
> 
> Hi All,
> 
> I have applied Jagan's PCIe patch for Rockchip (
> http://lists.infradead.org/pipermail/linux-rockchip/2020-May/031117.html)
> to my Rock Pi 4 but I am getting intermittent results with the PCIe bus
> (and hence NVMe m.2) showing in u-boot (and then Linux).
> 
> When it is successful the pci command shows the pci bus as expected when it
> isnt working I get the following:
> => pci
> PCIe link training gen1 timeout!
> No such bus
> => pci enum
> failed to find ep-gpios property
> => fatload mmc 0:4 ${fdt_addr_r} rk3399-rock-pi-4.dtb
> 54702 bytes read in 21 ms (2.5 MiB/s)
> => fdt addr ${fdt_addr_r}
> => fdt set /pcie@f8000000 ep-gpios  <0xb7 27 0>
> => fdt print /pcie@f8000000 ep-gpios
> ep-gpios = <0x000000b7 0x0000001b 0x00000000>
> => pci
> failed to find ep-gpios property
> No such bus
> => pci enum
> failed to find ep-gpios property
> 
> I have 4 of these boards with the same intermittent results on all of them.
> It fails more then it succeeds and I have a combination of both booted into
> linux on my network at the moment.
> 
> When researching the issue I did see some commentary on a timing issue
> between training and bus scanning on rockchip and I am not sure if this is
> relevant to my problem.
> 
> Would appreciate any insights people may have and am very happy to work
> with people to troubleshoot the issue.

Might be worth trying:

https://patchwork.ozlabs.org/project/uboot/patch/20200427090947.75951-1-kette...@openbsd.org/

Reply via email to