Hi Dhananjay , Jagan,

On 2022-01-13 10:30, Dhananjay Phadke wrote:
On 1/13/2022 9:17 AM, Angus Ainslie wrote:
Add a JEDEC id for the Winbond W25Q16JV 16M-BIT serial flash memory with
DUAL/QUAD SPI

Changes since v1:

Updated the name for more suffixes

Signed-off-by: Angus Ainslie <an...@akkea.ca>
---
  drivers/mtd/spi/spi-nor-ids.c | 5 +++++
  1 file changed, 5 insertions(+)

diff --git a/drivers/mtd/spi/spi-nor-ids.c b/drivers/mtd/spi/spi-nor-ids.c
index b551ebd75e..3bd0ded443 100644
--- a/drivers/mtd/spi/spi-nor-ids.c
+++ b/drivers/mtd/spi/spi-nor-ids.c
@@ -314,6 +314,11 @@ const struct flash_info spi_nor_ids[] = {
                        SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ |
                        SPI_NOR_HAS_LOCK | SPI_NOR_HAS_TB)
        },
+       {
+               INFO("w25q16jv-im/jm", 0xef7015, 0, 64 * 1024,  32,
+                       SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ |
+                       SPI_NOR_HAS_LOCK | SPI_NOR_HAS_TB)
+       },

Shouldn't this be w25q16jvm, which seems to be unofficial convention for *-DTR parts? I was looking for naming convention for another Winbond part -

https://lore.kernel.org/u-boot/0c3e4727-0997-a4c5-dab1-b09ea8781...@linux.microsoft.com/


Would you like a v3 using this naming convention ?

Thanks
Angus

        {
                INFO("w25q32jv", 0xef7016, 0, 64 * 1024,  64,
                        SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ |

Reply via email to