On Tue, 16 Aug 2022 at 02:42, Stefan Herbrechtsmeier <[email protected]> wrote: > > From: Stefan Herbrechtsmeier <[email protected]> > > Simplify the comp_util class by remove duplicate code as preparation for > additional compress algorithms. > > Signed-off-by: Stefan Herbrechtsmeier <[email protected]> > > --- > > (no changes since v3) > > Changes in v3: > - Rename COMPRESSIONS to ALGORITHMS > - Rework existing comments > - Add _get_tool_name function comment > - Add _get_tool function comment > > tools/binman/cbfs_util_test.py | 2 +- > tools/binman/comp_util.py | 101 +++++++++++++++++++++++---------- > tools/binman/ftest.py | 2 +- > 3 files changed, 72 insertions(+), 33 deletions(-)
Reviewed-by: Simon Glass <[email protected]>

