On 2/26/24 11:43 AM, Sumit Garg wrote:
On Mon, 26 Feb 2024 at 14:24, Marek Vasut <[email protected]> wrote:

On 2/26/24 9:04 AM, Sumit Garg wrote:

[...]

+static int imx7_reset_assert_imx8mp(struct reset_ctl *rst)

Linux calls those imx8mp_reset_set() can co. which is less confusing
than imx7...imx8mp() , use it.


IMO, it would be more confusing if we choose two different naming
patterns for the same driver, see existing function names
imx7_reset_{deassert/assert}_imx* pattern.

Maybe create a patch which updates the naming scheme ?

Using two SoC names in one function name is confusing I think .

In fact, why not copy the code from Linux outright ?

I suppose the question here is to not convert the driver to use
regmap, right? If it is then that should be done as a separate cleanup
patch.

If it isn't too hard, please do the clean up first and then add the MX8MP bits on top.

[...]

Reply via email to