On Mon, Jun 15, 2026 at 10:22:47AM -0600, Tom Rini wrote: > On Mon, Jun 15, 2026 at 12:29:57PM +0530, Balaji Selvanathan wrote: > > > Rename the Kconfig symbol SPL_UFS_SUPPORT to SPL_UFS to align with > > the naming convention used by other SPL storage drivers (e.g., > > SPL_SATA, SPL_MMC). This shorter name also works cleanly with the > > $(PHASE_) prefix macro in Makefiles, allowing uniform use of > > CONFIG_$(PHASE_)UFS across SPL and TPL build rules. > > > > Remove the unnecessary `depends on UFS` from SPL_UFS. This dependency > > is not needed because SPL_UFS is a build-time option that can be > > independently controlled. > > The problem is that in drivers/ufs/Makefile we have: > obj-$(CONFIG_UFS) += ufs-uclass.o > > So we only get the uclass with CONFIG_UFS=y. Can you build a boot a > CONFIG_UFS=y CONFIG_SPL_UFS=y target with your series? I expect there's > problems. > > [snip] > > diff --git a/drivers/Makefile b/drivers/Makefile > > index 43d0ba33281..86a54b5f332 100644 > > --- a/drivers/Makefile > > +++ b/drivers/Makefile > > @@ -73,7 +73,7 @@ obj-$(CONFIG_SPL_USB_HOST) += usb/host/ > > obj-$(CONFIG_SPL_SATA) += ata/ scsi/ > > obj-$(CONFIG_SPL_LEGACY_BLOCK) += block/ > > obj-$(CONFIG_SPL_THERMAL) += thermal/ > > -obj-$(CONFIG_SPL_UFS_SUPPORT) += scsi/ ufs/ > > +obj-$(CONFIG_SPL_UFS) += scsi/ ufs/ > > > > endif > > endif > > This isn't great, and I'd like to see the relevant part of the Makefile > itself cleaned up to be: > obj-$(CONFIG_$(PHASE_)UFS)) += scsi/ ufs/ > (and so drop the unconditional obj-y += ufs). > > I don't see anyone upstream yet enabling SPL_UFS_SUPPORT so there's > likely some more general Kconfig updates / additions needed here.
... and here's me being a tiny bit unhappy about new platforms ending up in the master branch, post the next branch branch-point. That said, they of course both set CONFIG_UFS and CONFIG_SPL_UFS_SUPPORT today, so my general comments still apply. -- Tom
signature.asc
Description: PGP signature

