Dear Joakim Tjernlund, > > Hello Marek, > > > > On 5/25/2012 7:44 PM, Marek Vasut wrote: > > > This patch conditionally defines flush_dcache_range() and > > > invalidate_dcache_range() on MPC8xxx, to avoid EHCI complaining, > > > > > resulting in the following output: > > <snip> > > > > > + > > > +void invalidate_dcache_range(unsigned long start, unsigned long stop) > > > +{ > > > +} > > > + > > > +void flush_dcache_range(unsigned long start, unsigned long stop) > > > +{ > > > +} > > > > Don't mind if this is a stupid question. > > Can't this be placed in some common header? > > Just to avoid code duplication! > > And why are they just dummy functions? There are cache flush instructions > for ppc
Doesn't the PPC have it's own internal snooping? Best regards, Marek Vasut _______________________________________________ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot