Hi Johan,

On 7/24/26 12:17 AM, Johan Jonker wrote:
Not all Rockchip SoC models use the ARM arch timer.
Call the function timer_init() only when
CONFIG_SYS_ARCH_TIMER is available.
Replace the ifdef call condition by IS_ENABLED
to increase build coverage and make the code easier to read.

Signed-off-by: Johan Jonker <[email protected]>
Reviewed-by: Simon Glass <[email protected]>
---

Previous version not needed for serie, so resend separate.
https://patchwork.ozlabs.org/project/uboot/patch/[email protected]/


You didn't answer Kever's question in the linked patch and I have the same question.

This is essentially the same code, so what's the benefit, are you trying to fix a specific issue? How does this improve the situation?

How does doing that increase code coverage... etc :)

Cheers,
Quentin

Reply via email to