Hi Anders, Thank you for the patch.
On Thu, Jul 16, 2026 at 15:41, Anders Roxell <[email protected]> wrote: > From: Jens Wiklander <[email protected]> > > Sync Linux kernel dwc3 changes from v4.6 to v4.7. > > The following files are preserved accross the import: > Makefile Kconfig dwc3-meson-g12a.c dwc3-meson-gxl.c dwc3-omap.c > dwc3-uniphier.c dwc3-generic.h dwc3-generic.c dwc3-generic-sti.c > dwc3-layerscape.c ti_usb_phy.c > > Skipping unused files: > debugfs.c drd.c dwc3-exynos.c dwc3-haps.c dwc3-imx8mp.c dwc3-keystone.c > dwc3-octeon.c dwc3-of-simple.c dwc3-pci.c dwc3-qcom.c dwc3-qcom-legacy.c > dwc3-rtk.c dwc3-st.c dwc3-xilinx.c host.c trace.c trace.h ulpi.c > > Note that this is a raw import and doesn't build. > A fixup commit at the end of the series fixes that. > > List of commits: git log --oneline v4.6..v4.7 > Commits imported: > 5baaf3b9efe1 usb: dwc3: st: Use explicit reset_control_get_exclusive() API > 002f17bc54ff usb: dwc3: st: Inform the reset framework that our reset line > may be shared > 50c763f8c1ba usb: dwc3: Set the ClearPendIN bit on Clear Stall EP command > 27a0faafdca5 usb: dwc3: st: Fix USB_DR_MODE_PERIPHERAL configuration. > 4879efb34f7d usb: dwc3: exynos: Fix deferred probing storm. > 973986126a41 usb: dwc3: gadget: fix mask and shift order in DWC3_DCFG_NUMP() > 2a58f9c12bb3 usb: dwc3: gadget: disable automatic calculation of ACK TP NUMP > 676e34974481 usb: dwc3: gadget: update DCFG.NumP to max burst size > 7b9cc7a2b101 usb: dwc3: gadget: give better command return code > ce046d323d74 usb: dwc3: pci: pass the platform device as a parameter to > dwc3_pci_quirks() > 474799f07376 usb: dwc3: pci: make build-in device properties available > ae4114137607 usb: dwc3: ep0: sanity check test mode selector > 818ec3aba883 usb: dwc3: debugfs: dump out endpoint details > b058f3e8a399 usb: dwc3: core: add helper to extract trb type > cf6d867d3b57 usb: dwc3: core: add fifo space helper > 4e9f311833a9 usb: dwc3: make dwc3_debugfs_init return value be void > af566a0be6e4 usb: dwc3: omap: get rid of dma_status > 8e7046b71dae usb: dwc3: gadget: don't interrupt when chained > 052ba52efa17 usb: dwc3: gadget: remove newline from trace > 36b68aae8e39 usb: dwc3: gadget: use link TRB for all endpoint types > 4faf75504a7d usb: dwc3: gadget: move % operation to increment helpers > ef966b9d3353 usb: dwc3: gadget: add trb enqueue/dequeue helpers > 70fdb273db37 usb: dwc3: get rid of DWC3_TRB_MASK > c28f82595dde usb: dwc3: switch trb enqueue/dequeue and first_trb_index to u8 > 5ef68c56e169 usb: dwc3: core: document struct dwc3_request > 53fd88189e08 usb: dwc3: gadget: rename busy/free_slot to trb_enqueue/dequeue > 495dd5f78145 usb: dwc3: omap: drop dma_mask configuration > e58dd357741b usb: dwc3: add disable receiver detection in P3 quirk > c36d8e947a56 usb: dwc3: gadget: put link to U0 before Start Transfer > 218ef7b647e3 usb: dwc3: gadget: extract unlocked dwc3_gadget_wakeup() > 2b0f11df84bb usb: dwc3: gadget: clear SUSPHY bit before ep cmds > c0ca324d09a0 usb: dwc3: gadget: combine return points into a single one > dea520a4a283 usb: dwc3: gadget: pass ev_buff as cookie to irq handler > 696c8b128220 usb: dwc3: drop ev_buffs array > 660e9bde74d6 usb: dwc3: remove num_event_buffers > aa3342c8bb61 usb: dwc3: better name for our request management lists > 8495036e986b usb: dwc3: increase maximum number of TRBs per endpoint > ca4d44ea2a91 usb: dwc3: gadget: always enable CSP > bc5081617fae usb: dwc3: drop FIFO resizing logic > > Signed-off-by: Jens Wiklander <[email protected]> > Reviewed-by: Simon Glass <[email protected]> > Signed-off-by: Anders Roxell <[email protected]> I've file-compared with the mentioned Linux kernel release, and this looks good to me: Reviewed-by: Mattijs Korpershoek <[email protected]>
