From: Denis Mukhin <[email protected]> Use cpu_hlt() instead of open-coded "hlt" in pch_sysreset_power_off().
Signed-off-by: Denis Mukhin <[email protected]> Reviewed-by: Simon Glass <[email protected]> --- Original patch: https://lore.kernel.org/u-boot/[email protected]/ --- drivers/sysreset/sysreset_x86.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/sysreset/sysreset_x86.c b/drivers/sysreset/sysreset_x86.c index c2f28c65280f..05a3ff9c8363 100644 --- a/drivers/sysreset/sysreset_x86.c +++ b/drivers/sysreset/sysreset_x86.c @@ -65,7 +65,7 @@ int pch_sysreset_power_off(struct udevice *dev) outl(reg32, pm.base + pm.pm1_cnt_ofs); for (;;) - asm("hlt"); + cpu_hlt(); } static int x86_sysreset_request(struct udevice *dev, enum sysreset_t type) -- 2.54.0
