From: Denis Mukhin <[email protected]> Use existing BOOT_PART_TYPE symbol instead of open-coded "U-Boot".
Signed-off-by: Denis Mukhin <[email protected]> --- disk/part_efi.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/disk/part_efi.c b/disk/part_efi.c index d8b17ec2e91a..1efd2ea113f0 100644 --- a/disk/part_efi.c +++ b/disk/part_efi.c @@ -304,7 +304,7 @@ static int __maybe_unused part_get_info_efi(struct blk_desc *desc, int part, snprintf((char *)info->name, sizeof(info->name), "%s", print_efiname(&gpt_pte)); - strcpy((char *)info->type, "U-Boot"); + strcpy((char *)info->type, BOOT_PART_TYPE); info->bootable = get_bootable(&gpt_pte); info->type_flags = gpt_pte.attributes.fields.type_guid_specific; if (CONFIG_IS_ENABLED(PARTITION_UUIDS)) { -- 2.54.0
