Hey Jan

On Thu, 17 Sept 2026 at 13:32, Jan Kiszka <[email protected]> wrote:
>
> On 17.09.26 12:24, Ilias Apalodimas wrote:
> > On Thu, 10 Sept 2026 at 08:56, Jan Kiszka <[email protected]> wrote:
> >>
> >> From: Jan Kiszka <[email protected]>
> >>
> >> This is needed to that OP-TEE can re-enumerate services which need RPMB
> >> access that may have become available now.
> >>
> >> Signed-off-by: Jan Kiszka <[email protected]>
> >> Reviewed-by: Peng Fan <[email protected]>
> >> Reviewed-by: Tanmay Kathpalia <[email protected]>
> >> ---
> >> CC: Peng Fan <[email protected]>
> >> CC: Jaehoon Chung <[email protected]>
> >> ---
> >>  drivers/mmc/mmc.c | 4 ++++
> >>  1 file changed, 4 insertions(+)
> >>
> >> diff --git a/drivers/mmc/mmc.c b/drivers/mmc/mmc.c
> >> index 670e92ee12b..2463e50cd3c 100644
> >> --- a/drivers/mmc/mmc.c
> >> +++ b/drivers/mmc/mmc.c
> >> @@ -27,6 +27,7 @@
> >>  #include <linux/list.h>
> >>  #include <linux/printk.h>
> >>  #include <div64.h>
> >> +#include <tee/optee.h>
> >>  #include "mmc_private.h"
> >>
> >>  #define DEFAULT_CMD6_TIMEOUT_MS  500
> >> @@ -3168,6 +3169,9 @@ int mmc_init(struct mmc *mmc)
> >>                                 mmc->cfg->name);
> >>         }
> >>
> >> +       if (CONFIG_IS_ENABLED(OPTEE) && mmc->capacity_rpmb > 0)
> >
> > This is only used in used in U-Boot proper right? We don't have
> > SPL/TPL symbols for RPMB support, so IS_ENABLED() is better
> >
>
> Can change that. Can send a v5, unless this is something that could be
> fixed up on merge.

I am goign through patch #3. If that's ok I can fix this up during the merge.

>
> For my understanding: Would that be for clarity purposes, or is there a
> practical advantage of limiting the check?

Clarity, CONFIG_IS_ENABLED() checks for both TPL/SPL symbols as well,
but we dont have any of these in SPL.

Cheers
/Ilias
>
> Thanks,
> Jan
>
> --
> Siemens AG, Foundational Technologies
> Linux Expert Center

Reply via email to