On Fri, 18 Sept 2026 at 23:06, Jorge Ramirez-Ortiz <[email protected]> wrote: > > rpmb.c implements the legacy single-command RPMB supplicant, which is > eMMC-only. Rename it to rpmb_emmc.c to make room for a UFS backend. > > No functional change. > > Signed-off-by: Jorge Ramirez-Ortiz <[email protected]> > ---
Reviewed-by: Ilias Apalodimas <[email protected]> > drivers/tee/optee/Makefile | 2 +- > drivers/tee/optee/{rpmb.c => rpmb_emmc.c} | 0 > 2 files changed, 1 insertion(+), 1 deletion(-) > rename drivers/tee/optee/{rpmb.c => rpmb_emmc.c} (100%) > > diff --git a/drivers/tee/optee/Makefile b/drivers/tee/optee/Makefile > index 36ac085ef42..d0c7f8dfb12 100644 > --- a/drivers/tee/optee/Makefile > +++ b/drivers/tee/optee/Makefile > @@ -3,4 +3,4 @@ > obj-$(CONFIG_OPTEE) += core.o > obj-y += supplicant.o > obj-$(CONFIG_DM_I2C) += i2c.o > -obj-$(CONFIG_SUPPORT_EMMC_RPMB) += rpmb.o > +obj-$(CONFIG_SUPPORT_EMMC_RPMB) += rpmb_emmc.o > diff --git a/drivers/tee/optee/rpmb.c b/drivers/tee/optee/rpmb_emmc.c > similarity index 100% > rename from drivers/tee/optee/rpmb.c > rename to drivers/tee/optee/rpmb_emmc.c > -- > 2.54.0 >
