Hi Maniyam,

On Fri, 26 Jun 2026 02:08:25 +0800, Dinesh Maniyam <[email protected]> wrote:

diff --git a/configs/socfpga_arria10_qspi_defconfig 
b/configs/socfpga_arria10_qspi_defconfig
@@ -0,0 +1,8 @@
+CONFIG_DEFAULT_DEVICE_TREE="socfpga_arria10_socdk_qspi"
+CONFIG_DEFAULT_FDT_FILE="socfpga_arria10_socdk_qspi.dtb"
[...]
+CONFIG_DEFAULT_DEVICE_TREE="socfpga_arria10_socdk_nand"

B1: New SoCDK QSPI/NAND DTBs are not registered in arch/arm/dts/Makefile.

The defconfigs point DEFAULT_DEVICE_TREE at socfpga_arria10_socdk_{qspi,nand}, but dtb-$(CONFIG_ARCH_SOCFPGA) still only lists socfpga_arria10_socdk_sdmmc.dtb (the Makefile hunk is missing from this series). Please add both .dtb entries next to
sdmmc so `make <defconfig> && make -j dtbs` produces them.

diff --git a/configs/socfpga_arria10_nand_defconfig 
b/configs/socfpga_arria10_nand_defconfig
@@ -0,0 +74,11 @@
+CONFIG_NAND_DENALI_DT=y
+CONFIG_SPL_NAND_CADENCE=y
[...]

B2: SPL selects SPL_NAND_CADENCE while Arria 10 NAND is Denali
(compatible = "altr,socfpga-denali-nand").

Please use CONFIG_SPL_NAND_DENALI=y (see secu1 precedent) instead of CADENCE;
add NAND_DENALI_SPARE_AREA_SKIP_BYTES if the handoff requires it.

diff --git a/arch/arm/dts/socfpga_arria10_socdk_nand.dts 
b/arch/arm/dts/socfpga_arria10_socdk_nand.dts
@@ -0,0 +18,9 @@
+                       reg = <0x0 0x02500000>;
+               };
+               partition@1c00000 {
+                       label = "Root Filesystem - JFFS2";
+                       reg = <0x02500000 0x05500000>;

N1: partition unit-address @1c00000 does not match reg start 0x02500000.

Please rename to partition@2500000 (or correct reg if 0x1c00000 was intended).

diff --git a/arch/arm/dts/socfpga_arria10_socdk_qspi.dts 
b/arch/arm/dts/socfpga_arria10_socdk_qspi.dts
@@ -0,0 +1,11 @@
+&qspi {
+       status = "okay";
+};

N3: QSPI DT enables the controller only — no MTD partitions for the documented
env / root=mtdblock1 layout.

Please add flash partitions matching the README/env, or document that partitions
are created at runtime and drop mtdblock assumptions.

Overall: P1 CFG_IO rename looks fine. Please respin P3 for B1/B2 (and the nits
above) before merge.

Best regards,
Tien Fong

Reply via email to