Il giorno mar 27 ott 2026 alle ore 19:00 Quentin Schulz ha scritto:
>
> Hi Massimo,
>
> On 10/18/26 5:59 PM, Massimo Pegorer wrote:
> > The primary branch name is main, not master anymore. Update references
> > still naming it master in the documentation, replacing master with main.
> >
> > Signed-off-by: Massimo Pegorer <[email protected]>
> > ---
> >   doc/CONTRIBUTE.rst              |  6 +++---
> >   doc/develop/sending_patches.rst | 12 ++++++------
> >   tools/buildman/buildman.rst     |  8 ++++----
> >   3 files changed, 13 insertions(+), 13 deletions(-)
> >
> > diff --git a/doc/CONTRIBUTE.rst b/doc/CONTRIBUTE.rst
> > index e0394515702..b012648e3f2 100644
> > --- a/doc/CONTRIBUTE.rst
> > +++ b/doc/CONTRIBUTE.rst
> > @@ -73,11 +73,11 @@ considered as reasonable amount of time.
> >   Development Branches
> >   --------------------
> >
> > -The U-Boot developers use two main branches for developing the code. The 
> > master
> > +The U-Boot developers use two primary branches for developing the code. 
> > The main
> >   branch is used for the current development cycle, while there is also a 
> > next
> >   branch intended to land changes for the next release early to enable wider
> > -testing of larger code changes. The next branch is merged to master shortly
> > -after the tagging of a new major release.
> > +testing of larger code changes. The next branch is merged to main shortly 
> > after
> > +the tagging of a new major release.
> >
>
> I think this paragraph would benefit from highlighting the main and next
> word with double tick quotes like we do later in this diff in the next
> file. Can be done in a follow-up patch though.

Added in v2.

>
> >   Similar to Linux there is a three week merge window post release after 
> > which a
> >   release candidate is tagged. There's typically a new release candidate 
> > every
> > diff --git a/doc/develop/sending_patches.rst 
> > b/doc/develop/sending_patches.rst
> > index b4f82eb18e1..8b8a70da4bb 100644
> > --- a/doc/develop/sending_patches.rst
> > +++ b/doc/develop/sending_patches.rst
> > @@ -36,7 +36,7 @@ configuration file and ``scripts/get_maintainer.pl``.
> >   .. code-block:: bash
> >
> >      b4 prep -n mmc-fixes
> > -   git rebase -i origin/master
> > +   git rebase -i origin/main
> >      b4 prep --edit-cover
> >      b4 prep --auto-to-cc
> >
> > @@ -65,7 +65,7 @@ fold them into your commits before resending the updated 
> > series.
> >   .. code-block:: bash
> >
> >      b4 trailers -u
> > -   git rebase -i origin/master
> > +   git rebase -i origin/main
> >      b4 send
> >
> >   Using patman
> > @@ -132,11 +132,11 @@ General Patch Submission Rules
> >   * Send your patches as plain text messages: no HTML, no MIME, no links, no
> >     compression, no attachments. Just plain text. The best way to generate
> >     patches is by using the ``git format-patch`` command. For a patch that 
> > is
> > -  fixing a bug or regression of some sort, please use the ``master`` 
> > branch of
> > +  fixing a bug or regression of some sort, please use the ``main`` branch 
> > of
> >     the mainline U-Boot git repository located at
> >     https://git.u-boot-project.org/u-boot/u-boot.git as reference. For new 
> > features, if
> >     the ``next`` branch has been opened (which happens with the release of
> > -  ``-rc2``) that branch should be used, otherwise ``master`` is acceptable.
> > +  ``-rc2``) that branch should be used, otherwise ``main`` is acceptable.
> >
> >   * Make sure that your mailer does not mangle the patch by automatic 
> > changes
> >     like wrapping of longer lines etc.
> > @@ -452,8 +452,8 @@ today. Not all states are used by all custodians.
> >     it will be accepted for mainline.
> >
> >   * Awaiting Upstream: A custodian may have applied this to the ``next`` 
> > branch
> > -  and has not merged yet to master, or has queued the patch up to be 
> > submitted
> > -  to be merged, but has not yet.
> > +  and has not merged yet to ``main`` one, or has queued the patch up to be
>
> Spurious "one" here?

Removed in v2.

Thanks. Regards.
Massimo

>
> Looks good to me otherwise.
>
> Cheers,
> Quentin

Reply via email to