So are these MV fields or SV fields?  Also, you only have a
process-after on the Earned Date?  Nothing on the LI# or Award fields?
I'm also assuming your sequence of prompting in the screen is straight
forward, left to right for these 4 prompts, and you have no extra
processes on the DICT entries for these.  You said they are just @WORK
variables, right?


-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Lunt, Bruce
Sent: Monday, March 12, 2012 1:53 PM
To: 'U2 Users List'
Subject: Re: [U2] SB+ screen question

Hi Bob,

Thanks for the reply. I agree with you - Kevin's book is fantastic! I
have been using it for many years and still refer to it when I need
guidance. As for the problem: Maybe I am using the wrong processing
slot.  What I have is something like this:

LI#   Award     Earned Date     Paid Date
---   -----     -----------     -----------
999   xxxxx     DD MMM YYYY     DD MMM YYYY

I have the LI# field as input but do nothing else with it. I have the
Award field as no input; display only. I have the Earned Date field as
input with a Process After process to determine what to do with the Paid
Date. In the process I will populate the Paid Date if it is not already
there. I will change the Paid Date to be the same as the Earned Date if
the Earned Date was changed and the Paid date was the same as the
original Earned Date. If the Paid Date is not the same as the original
Earned Date I will leave the Paid Date alone. And lastly, the Paid Date
field is diplay only.

To me, this means that I have to prompt the user for the Earned Date - I
cannot skip the field until I know if they are wanting to change the
field so I then will know what to do with the Paid Date. If they do not
change the Earned Date then I will leave the Paid Date as it is.

I also put a DISP line showing the value of the original Earned Date and
the current one in the Process After for the Earned Date and it will
show correctly the first time I enter the screen (after I hit enter in
the the Earned Date field.) but it will show after I enter the LI#
field, the next time I open the screen and skip the Earned Date field. 

Thanks again,
Bruce



-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Woodward, Bob
Sent: Monday, March 12, 2012 12:09 PM
To: U2 Users List
Subject: Re: [U2] SB+ screen question


Hi Bruce,

It may have to do with your concept of how the work flow is going in
screen and the way your process is working to control your entry.  If
you have access to a copy of Kevin King's green System Builder book "SB+
Solutions", check the sections in "Special Processing for Multivalued
Fields" starting on page 3-145.  Specifically where it talks about the
fact that in an Multivalue field, the Process Before the Prompt is only
executed one time for the first value, not before each value of the
field.  This might be where you're having the problem.

I love this book, by the way!!!  Thanks Kevin!

BobW

-----Original Message-----
From: u2-users-boun...@listserver.u2ug.org
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Lunt, Bruce
Sent: Monday, March 12, 2012 10:40 AM
To: u2-users@listserver.u2ug.org
Subject: [U2] SB+ screen question

Hi All,
 
I have created a new screen in SB+. The data is built into the work
record and then I want to have the user be able to go through the lines
one at a time in order to change a date field. The date field itself
will only be able to be changed when another associated date field is
not already present. I have the screen working pretty well except for
something strange that is happening. That is, I can call the screen up
from the menu and when I hit enter at the first line it move over to the
the date to be modified.
But when I exit the screen and come back into it, the cursor will not
move over to the date but just down to the next line, and the next line
again if I continue to hit the enter key. It never goes over to the date
field, just down a line. When it reaches the bottom of the data it
cycles back to line one and continues to go down the page with each
enter key. Now it gets really interesting. When I exit the screen and
then go back into the screen it will work correctly. And if I exit and
re-enter it will fail again. It just toggles between working correctly
and not working at all.
 
I have tried to debug this by putting in DISP statements into the
Process After Display (the first process is called from here) but I do
not see what is causing the screen to react the way that it is.
 
I don't know if I have explained it very well but has anybody else had
this problem before and know how to fix it?
 
Thanks in advance,
Bruce
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users
_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users

Reply via email to