Kevin,

This is a long shot, an Is-it-plugged-In-Category question, but you might as well check:

On UV I got bit recently using numbered select lists because "1", "2", ... were custom items in the VOC. Some commands recognized the numbered select lists on the command line; but some read the VOC and got confused.

cds

On 9/24/2012 11:43 AM, Kevin King wrote:
How does one manage multiple active select lists in Unidata?  I could have
sworn I've done this before, but for some reason it's not working at all as
I recall.

I have this SUBR(..) type field in file A that selects records from file B
to calculate an aggregate.  This works fine when listing file A and showing
the field.  However, if there's an active select list when file A is listed
with this field, the select statement in my SUBR(..) is consuming the
active select list 0 and returning incorrect results.

My subroutine is $BASICTYPE "U" and is selecting records using the lower
case select and selecting to active list #3.  It then processes from list
#3 and returns its result.  I've tried using the RTNLIST and PASSLIST
options on the EXECUTE statements and I get a "Misuse of Reserved Word
'PASSLIST'" or "Misuse of Reserved Word 'RTNLIST'".  I've tried UDTEXECUTE
with no compilation errors but also no improvement on the problem.  I've
even tried MDPERFORM but I get the misuse errors with the RTNLIST and
PASSLIST options.  Oddly enough, removing $BASICTYPE "U" I don't get an
error on MDPERFORM but I can't READNEXT from a numbered select without the
$BASICTYPE "U".

How should I structure this SUBR(..) so that it does not consume list 0
when selecting to list 3?


_______________________________________________
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users

Reply via email to