My main problem is resolved but your suggestions raised some other
questions, Larry.

When I take the initial WEOFSEQ out, the first run will produce the
result I need. But if I run the program again, the error statement is
returned each time the WRITESEQ statement is executed.  When WEOFSEQ is
executed right after the OPEN... statement, I get the desired result
each time I run it...also, the APPEND is no longer in the WRITE...

Something else I don't understand:
When the file to be created/refreshed doesn't exist in X.DIR, the error
message of the OPEN... statement is returned. Even so, the new file is
created and written to, and I receive the desired result.  I don't get
that one.  This happens with or without the PCPERFORM command.

-----Original Message-----
From: Larry Hiscock [mailto:[EMAIL PROTECTED] 
Sent: Tuesday, April 13, 2004 12:50 PM
To: 'U2 Users Discussion List'

If you don't position the file with READSEQ, and you don't use the
APPEND clause on WRITESEQ, it should overwrite the file from the
beginning.  The initial WEOFSEQ should be unnecessary, and in fact is
probably why you're only seeing an empty file.  We use sequential file
processing in a number of programs, including data transfer to/from a
webserver, EDI, data export to other applications, etc.
u2-users mailing list

Reply via email to