This bug was fixed in the package libqofono -
0.90+16.10.20160901-0ubuntu1

---------------
libqofono (0.90+16.10.20160901-0ubuntu1) yakkety; urgency=medium

  * New upstream release
  * debian/control
    - Dropped recommends for ofono to a suggests
    - Renamed QML module to follow qml-module-ofono naming (LP: #1342031)

 -- Ken VanDine <ken.vand...@canonical.com>  Thu, 01 Sep 2016 14:59:50
+0000

** Changed in: libqofono (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Apps bug tracking, which is subscribed to history-service in Ubuntu.
https://bugs.launchpad.net/bugs/1342031

Title:
  Rename QML modules to follow qml-module-foo naming

Status in accounts-qml-module package in Ubuntu:
  Fix Released
Status in address-book-app package in Ubuntu:
  New
Status in bacon2d package in Ubuntu:
  Triaged
Status in clickmanager-plugin package in Ubuntu:
  New
Status in content-hub package in Ubuntu:
  New
Status in cordova-ubuntu package in Ubuntu:
  New
Status in dee-qt package in Ubuntu:
  New
Status in gsettings-qt package in Ubuntu:
  New
Status in history-service package in Ubuntu:
  New
Status in libhud-qt package in Ubuntu:
  Won't Fix
Status in libqofono package in Ubuntu:
  Fix Released
Status in libusermetrics package in Ubuntu:
  New
Status in mediascanner2 package in Ubuntu:
  Fix Released
Status in oxide-qt package in Ubuntu:
  New
Status in poppler-qml-plugin package in Ubuntu:
  New
Status in qml-box2d package in Ubuntu:
  New
Status in qml-friends package in Ubuntu:
  New
Status in qt3d-opensource-src package in Ubuntu:
  Fix Released
Status in qtconnectivity-opensource-src package in Ubuntu:
  Fix Released
Status in qtdeclarative-opensource-src package in Ubuntu:
  Fix Released
Status in qtfeedback-opensource-src package in Ubuntu:
  Fix Released
Status in qtgrilo package in Ubuntu:
  New
Status in qtlocation-opensource-src package in Ubuntu:
  Fix Released
Status in qtmultimedia-opensource-src package in Ubuntu:
  Fix Released
Status in qtpim-opensource-src package in Ubuntu:
  Fix Released
Status in qtquickcontrols-opensource-src package in Ubuntu:
  Fix Released
Status in qtsensors-opensource-src package in Ubuntu:
  Fix Released
Status in qtsystems-opensource-src package in Ubuntu:
  Fix Released
Status in reminders-app package in Ubuntu:
  New
Status in solid package in Ubuntu:
  New
Status in sync-monitor package in Ubuntu:
  New
Status in telephony-service package in Ubuntu:
  Triaged
Status in thumbnailer package in Ubuntu:
  Fix Released
Status in u1db-qt package in Ubuntu:
  Confirmed
Status in ubuntu-download-manager package in Ubuntu:
  Triaged
Status in ubuntu-keyboard package in Ubuntu:
  New
Status in ubuntu-settings-components package in Ubuntu:
  In Progress
Status in ubuntu-system-settings-online-accounts package in Ubuntu:
  Fix Released
Status in ubuntu-ui-extras package in Ubuntu:
  New
Status in ubuntu-ui-toolkit package in Ubuntu:
  Fix Released
Status in ubuntuone-credentials package in Ubuntu:
  Fix Released
Status in unity-action-api package in Ubuntu:
  Triaged
Status in unity-notifications package in Ubuntu:
  New
Status in webbrowser-app package in Ubuntu:
  Fix Released
Status in ubuntu-ui-toolkit package in Ubuntu RTM:
  Fix Released

Bug description:
  UPDATE: This would be a nice to have for Ubuntu 16.04 LTS, since
  otherwise we will need to keep the transitional packages until 2018.

  
  ===

  The package names of QML modules should be of the format qml-
  module-{$modulename}[version], a transition that was started during Qt
  5.3 preparation in Ubuntu. For example this could be qml-module-
  qtquick-localstorage or qml-module-qtsysteminfo for non versioned
  modules, and qml-module-ubuntu-webthing0.3 for versioned/co-
  installable modules.

  Further details in Debian e-mail:
  http://lists.alioth.debian.org/pipermail/pkg-kde-
  talk/2014-March/001889.html

  For Ubuntu, transitional packages should be put in place for smooth 
distribution upgrades, since we're shipping with the old names in previous 
Ubuntus. An example of that is at 
http://bazaar.launchpad.net/~kubuntu-packagers/kubuntu-packaging/qtsystems-opensource-src/revision/31
 - in other words:
  - Make the old package a transitional oldlibs package that depends on the new 
package
  - Add Breaks/Replaces to the new package for the old non-transitional 
packages (be careful about the version number specification)
  - Keep Multi-Arch: same and Architecture: any for the transitional package
  - Write "QML module" instead of "QML plugin"
  - Rename also the *.install files

  ---
  One more example on naming:

  For example, the "test" (qtdeclarative5-test-plugin) in the old
  qtdeclarative5-style package naming became "qttest" (qml-module-
  qttest) in the new naming since the path is actually under
  /usr/lib/*/qt5/qml/QtTest/

  qml-module-qtquick-xmllistmodel has path
  /usr/lib/*/qt5/qml/QtQuick/XmlListModel, as an example if you have
  more than one subdir. /usr/lib/*/qt5/qml/Ubuntu/Connectivity/ would be
  qml-module-ubuntu-connectivity.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/accounts-qml-module/+bug/1342031/+subscriptions

-- 
Mailing list: https://launchpad.net/~ubuntu-apps-bugs
Post to     : ubuntu-apps-bugs@lists.launchpad.net
Unsubscribe : https://launchpad.net/~ubuntu-apps-bugs
More help   : https://help.launchpad.net/ListHelp

Reply via email to