apport information

** Tags added: apport-collected uec-images

** Description changed:

  Hi ubuntu kernel team,
  
  I am compiling my own ubuntu kernel on ubuntu trusty, and I git clone 
https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux/+git/yakkety,  
the build almost success, but failed at the end with missing modules,  I 
haven't done any change for the source code :
  Then I start a docker container using xenial image,  try the same build 
steps,  I can successfullly build kernel deb pkgs .  Do you have idea why it 
throw missing module error on ubuntu trusty ?  Thanks .
  
  root@kbuild:~/yakkety# uname -a
  Linux kbuild 3.13.0-58-generic #97-Ubuntu SMP Wed Jul 8 02:56:15 UTC 2015 
x86_64 x86_64 x86_64 GNU/Linux
  root@kbuild:~/yakkety# apt-get build-dep linux-image-4.4.0-36-generic
  root@kbuild:~/yakkety# fakeroot debian/rules clean
  root@kbuild:~/yakkety# AUTOBUILD=1 fakeroot debian/rules binary-generic
  --------------ignore ----------------
  make[2]: Leaving directory `/root/yakkety/debian/build/build-generic'
  make[1]: Leaving directory `/root/yakkety'
  Debug: module-check-generic
  install -d /root/yakkety/debian.master/abi/4.4.0-34.53/amd64
  find /root/yakkety/debian/build/build-generic/ -name \*.ko | \
                  sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > 
/root/yakkety/debian.master/abi/4.4.0-34.53/amd64/generic.modules
  II: Checking modules for generic...
     reading new modules...read 4590 modules.
     reading old modules...
        MISS: spl
        MISS: splat
        MISS: zavl
        MISS: zcommon
        MISS: zfs
        MISS: znvpair
        MISS: zpios
        MISS: zunicode
        read 4598 modules : new(0)  missing(8)
  EE: Missing modules (start begging for mercy)
  make: *** [module-check-generic] Error 1
+ 
+ 
+ 
+ --- 
+ AlsaDevices:
+  total 0
+  crw-rw---- 1 root audio 116,  1 Sep 23 03:51 seq
+  crw-rw---- 1 root audio 116, 33 Sep 23 03:51 timer
+ AplayDevices: Error: [Errno 2] No such file or directory
+ ApportVersion: 2.14.1-0ubuntu3.16
+ Architecture: amd64
+ ArecordDevices: Error: [Errno 2] No such file or directory
+ AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
+ CRDA: Error: [Errno 2] No such file or directory
+ DistroRelease: Ubuntu 14.04
+ IwConfig: Error: [Errno 2] No such file or directory
+ Lsusb:
+  Bus 001 Device 002: ID 0627:0001 Adomax Technology Co., Ltd 
+  Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
+ MachineType: OpenStack Foundation OpenStack Nova
+ Package: linux (not installed)
+ PciMultimedia:
+  
+ ProcEnviron:
+  TERM=xterm
+  SHELL=/bin/bash
+  PATH=(custom, no user)
+  LANG=en_US.UTF-8
+ ProcFB:
+  
+ ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-58-generic 
root=UUID=80575ee5-f6ee-41e2-bab6-e4af1c26d1c1 ro nofb nomodeset vga=normal 
console=tty1 console=ttyS0
+ ProcVersionSignature: Ubuntu 3.13.0-58.97-generic 3.13.11-ckt22
+ RelatedPackageVersions:
+  linux-restricted-modules-3.13.0-58-generic N/A
+  linux-backports-modules-3.13.0-58-generic  N/A
+  linux-firmware                             1.127.16
+ RfKill: Error: [Errno 2] No such file or directory
+ Tags:  trusty uec-images
+ Uname: Linux 3.13.0-58-generic x86_64
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups:
+  
+ _MarkForUpload: True
+ dmi.bios.date: 01/01/2011
+ dmi.bios.vendor: Bochs
+ dmi.bios.version: Bochs
+ dmi.chassis.type: 1
+ dmi.chassis.vendor: Bochs
+ dmi.modalias: 
dmi:bvnBochs:bvrBochs:bd01/01/2011:svnOpenStackFoundation:pnOpenStackNova:pvr2015.1.2:cvnBochs:ct1:cvr:
+ dmi.product.name: OpenStack Nova
+ dmi.product.version: 2015.1.2
+ dmi.sys.vendor: OpenStack Foundation

** Attachment added: "BootDmesg.txt"
   
https://bugs.launchpad.net/bugs/1626838/+attachment/4746716/+files/BootDmesg.txt

-- 
You received this bug notification because you are a member of Ubuntu
Backporters, which is subscribed to trusty-backports.
Matching subscriptions: ubuntu-backporters
https://bugs.launchpad.net/bugs/1626838

Title:
  yakkety compiling failed on ubuntu trusty

To manage notifications about this bug go to:
https://bugs.launchpad.net/trusty-backports/+bug/1626838/+subscriptions

-- 
ubuntu-backports mailing list
ubuntu-backports@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports

Reply via email to