Hi,

> I tried xfburn prior to this bug report.

Then it must be older than version 0.5.2.
Try to get 0.5.2 or 0.5.4.


> I first renamed genisoimage and copied xorriso to its name. The error
> generated was 'unable to calculate file size'.
> ...
> xorriso : FAILURE : Cannot determine attributes of source file
> '/storage00/151206-Kubuntu64/etc/ssl/certs/NetLock_Arany_\=Class_Gold\=_Főta
> núsítvány.pem' : No such file or directory
> xorriso : FAILURE : Aborted reading of file '/tmp/kde-root/k3bK26520.tmp' in 
> line number 3223

This is probably a bug in xorriso's mkisofs emulation.
I assume that the file name contains '=' characters which K3B
tries to hide from the -graft-points feature of mkisofs.
Therefore it inserts '\' characters before the '='.
mkisofs will remove them. Obviously xorriso does not.

"/tmp/kde-root/k3bK26520.tmp" is probably the input file for
mkisofs option -path-list. A zillion of file names in it.

Now i have to find out whether xorriso is unaware of this
gesture or whether i broke it in the past it without noticing.


If you want to give the command line a try, then we could
compose a xorriso run which would probably work.
Something like

  xorriso -for_backup -outdev /dev/sr0 -blank as_needed -add /bin /boot
/etc /home /initrd.img /lib* /opt /root /sbin /usr /vmlinuz --

(I tested this with "-outdev stdio:/dev/null". The fastest
 burner ever. Up to 170x DVD speed. Regrettably it immediately
 forgets what is written to it.)

For repeated use, one would put this into a shell script so that it
can be executed by a single command word. One would write is a bit
more readable than in a single line:

  xorriso \
    -for_backup \
    -outdev /dev/sr0 \
    -blank as_needed \
    -add /bin /boot /etc /home /initrd.img /lib* /opt \
         /root /sbin /usr /vmlinuz --

(If you are not keen with shell scripting then i could give you
 a short intro. It's easy.)

One could also augment the script to do incremental backups with
several update runs to the same BD medium:
  "-dev /dev/sr0" instead of "-outdev /dev/sr0 -blank as_needed"
  "-update_r /bin /bin -update_r /boot /boot ..." instead of
  "-add ... --"


Have a nice day :)

Thomas

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1523326

Title:
  K3B (growisofs) too many directories

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/1523326/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to