** Description changed:

  <doko> hmm, syncpackage doesn't work in y. related to gpg?
+ 
+ $ syncpackage libabigail
+ Traceback (most recent call last):
+   File "/usr/bin/syncpackage", line 715, in <module>
+     main()
+   File "/usr/bin/syncpackage", line 615, in main
+     Launchpad.login(**kwargs)
+   File "/usr/lib/python2.7/dist-packages/ubuntutools/lp/lpapicache.py", line 
89, in login
+     version=api_version)
+   File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 
549, in login_with
+     credential_save_failed, version)
+   File "/usr/lib/python2.7/dist-packages/launchpadlib/launchpad.py", line 
352, in _authorize_token_and_login
+     authorization_engine.unique_consumer_id)
+   File "/usr/lib/python2.7/dist-packages/launchpadlib/credentials.py", line 
337, in load
+     return self.do_load(unique_key)
+   File "/usr/lib/python2.7/dist-packages/launchpadlib/credentials.py", line 
391, in do_load
+     'launchpadlib', unique_key)
+   File "/usr/lib/python2.7/dist-packages/keyring/core.py", line 42, in 
get_password
+     return _keyring_backend.get_password(service_name, username)
+   File "/usr/lib/python2.7/dist-packages/keyring/backends/fail.py", line 18, 
in get_password
+     raise RuntimeError("No recommended backend was available. Install the "
+ RuntimeError: No recommended backend was available. Install the keyrings.alt 
package if you want to use the non-recommended backends. See README.rst for 
details.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1624278

Title:
  syncpackge vs gnupg2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/+bug/1624278/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to