kernel-fixed-upstream should read kernel-semi-fixed-upstream as suspend
fails every second attempt

Below is the observed behaviour and how it could be implemented using an
'object' that could be a flag set in a file on persistent media such as
a hard disk

1a Whiskermenu Shutdown to switch PC off
1b Briefly press in power switch say for 2 secs to switch PC on
1c Object is set to 0 (capturing fact PC has just come out of completely 
powered down state)
1d Wait about 3 minutes
1e Observe PC works normally

2a Via whiskermenu select Suspend
2b If Object is set to 1 don't suspend (ignored)
2c Object is set to 1 (capturing fact suspend has been used once)
2d Green power LEDs (on power switch and on front of case) blink together every 
3 seconds approximately.
2e No other LEDs are on
2f Observe PC behaves as if suspended

3a Briefly press in power switch say for 2 secs to resume from suspend
3b Alternative place to set Object to 1
3c Observe PC resumes normally

4a Via whiskermenu select Suspend
4b If Object is set to 1 don't suspend (actioned)
4c Observe PC hangs with power switch LED on and front power LED both green and 
constant
4d also yellow LED on mute speaker key is on 
4e Brief presses on power button and Ctrl Alt Del etc have no affect
4f Only option left is press and hold Power button for about 6 secs to switch 
PC off

On same HP laptop Compaq nx6325 but with Ubuntu 14.04 (trusty) Kernel 
3.13.0-44-generic
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1416348
Suspend only works once, fails second time. Reported on 2015-01-30
Not yet adopted suggestion was to update the BIOS

mvacSSD:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
68TT2 Ver. F.06 12/21/2006 (The BIOS we are currently testing with)

http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=1849084&swLangOid=8&swEnvOid=1093
Three F.07 files are listed by HP (BIOS proposed to try)

https://help.ubuntu.com/community/BIOSUpdate
For HP use
http://support.hp.com/us-en/drivers/selfservice/HP-Pavilion-Elite-d5200-ATX-Desktop-PC-series/3824586/model/3824587

http://support.hp.com/us-en/document/c03101724
HP and Compaq Desktop PCs and Workstations - Updating the BIOS During Startup
---------
Others have reported similar behaviour
https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/1528735
Suspend fails every second time on some laptops in UEFI mode (Kenels 
4.2.0-22-generic x86_64 through to 4.8-rc1 as reported on 2016-08-16:)
---------
SUSPEND USING COMMAND LINE 1
Fresh power up
sudo pm-suspend (worked twice consecutively, power switch green LED blinks)
Start up firefox dropbox etc
sudo pm-suspend (suspend fails green power switch led on constant)

SUSPEND USING COMMAND LINE 2
http://askubuntu.com/questions/1792/how-can-i-suspend-hibernate-from-command-line
led to
http://askubuntu.com/questions/777178/suspend-command-in-ubuntu-16-04
systemctl suspend -i
Worked once failed next time same as sudo pm-suspend
---------
Further research
https://www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt
Debugging hibernation and suspend (C) 2007 Rafael J. Wysocki

https://sites.google.com/site/easylinuxtipsproject/bugs
Solutions for 17 bugs in Ubuntu 16.04

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1620733

Title:
  Xubuntu 16.04 on HP Compaq nx6325 freezes on Suspend

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1620733/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to