I had the same problem and unsuccessfully tried:

1. the linux-firmware package from yakkety
2. kernel-4.6.3-yakkety
3. kernel-4.7.4
4. sudo modprobe rt2800pci nohwcrypt=Y
5. sudo iw reg set NL

While the newer kernels seemed to alleviate the problem, they didn't fix

Then I reverted all the previously listed changes and turned the card's
power management off. That fixed it. However, since power management
would turn on every time it would connect to a network, I made a simple
NetworkManager script, that you can find at

The following are some relevant info about my system:

$ uname -a
Linux precision390 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 
x86_64 x86_64 x86_64 GNU/Linux

$ iwconfig
wlp5s5    IEEE 802.11abgn  ESSID:"<edited>"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: <edited>   
          Bit Rate=270 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=42/70  Signal level=-68 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:133  Invalid misc:781   Missed beacon:0

$ apt list linux-firmware
Listing... Done
linux-firmware/xenial-updates,xenial-updates,now 1.157.3 all 

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Very slow wireless with rt2800pci

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to