Public bug reported:

I upgraded from ubuntu 14.04 LTS to ubuntu 16.04 LTS. My wifi was working fine 
in previous version. But, after upgrade wifi broke. It won't show any wifi 
networks and I couldn't enable wifi from ubuntu panel on top right corner. 
I tried almost all suggestions in this page and few other askubuntu pages with 
same problem:
But, nothing worked. 

Here is my console output: 
~$ sudo rfkill list
0: dell-rbtn: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
7: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Then, I ran "sudo rfkill unblock wifi" but that didn't fix anything.

Finally, the only thing that worked was: 
sudo modprobe -r dell-rbtn

I don't even know if this is the right way to fix it. Please fix the
16.04 kernel and OS upgrade package so that other users don't face this
problem that cost me 2 days. Thank you.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.14
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sat Sep 17 15:13:39 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-08-19 (29 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: ubuntu-release-upgrader
Symptom: release-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

** Affects: ubuntu-release-upgrader (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug dist-upgrade xenial

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  wifi broke after 16.04 upgrade

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to