apport checks for a bug pattern before filing a bug report, in the case
of the bug which you were reporting it matched the bug pattern for bug
996916.  That pattern looks like:

    <pattern url="https://launchpad.net/bugs/996916";>
        <re key="Package">^(ubuntu-release-upgrader-core |update-manager)</re>
        <re key="VarLogDistupgradeMainlog">blacklist expr 
'\^postgresql-.*\[0-9\]\\.\[0-9\].*' matches</re>
    </pattern>

>From the bugs I'd seen before most of them failed to calculate the
upgrade, however in your log file (Mainlog.txt) the message appears
during the obsolete package check.

2016-09-18 12:53:10,503 DEBUG Start checking for obsolete pkgs
2016-09-18 12:53:18,126 DEBUG blacklist expr 'update-manager-core' matches 
'update-manager-core'
2016-09-18 12:53:18,127 DEBUG skipping 'update-manager-core' (in 
removalBlacklist)
2016-09-18 12:53:18,127 DEBUG 'update-manager-core' scheduled for remove but 
not safe to remove, skipping
2016-09-18 12:53:23,737 DEBUG blacklist expr 'update-manager-core' matches 
'update-manager-core'
2016-09-18 12:53:23,737 DEBUG package 'python3-distupgrade' has unwanted 
removals, skipping
2016-09-18 12:53:25,652 DEBUG 'python3-distupgrade' scheduled for remove but 
not safe to remove, skipping
2016-09-18 12:53:25,980 DEBUG blacklist expr '^postgresql-.*[0-9]\.[0-9].*' 
matches 'postgresql-9.3'
2016-09-18 12:53:25,980 DEBUG skipping 'postgresql-9.3' (in removalBlacklist)
2016-09-18 12:53:25,980 DEBUG 'postgresql-9.3' scheduled for remove but not 
safe to remove, skipping

The bug pattern should be modified so that it only matches bugs where
the message appears before upgrading.


** Changed in: apport (Ubuntu)
       Status: New => Triaged

** Changed in: apport (Ubuntu)
   Importance: Undecided => High

** Package changed: apport (Ubuntu) => apport

** Summary changed:

- ubuntu-bug refuses to file upgrade bug, thinks it's a dupe from 2012
+ bug pattern for bug 996916 not specific enough

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1624836

Title:
  bug pattern for bug 996916 not specific enough

To manage notifications about this bug go to:
https://bugs.launchpad.net/apport/+bug/1624836/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to