After so long time this bug is still present. I gave up with Ubuntu server 
14.04 and in 16.04 I encountered the same bug. You can't install Ubuntu server 
with RAID setup from installer. 
After spending hours and tried to find what was the difference I made with 
Gentoo setup that worked perfectly well and finaly managed to install Ubuntu 
Server on RAID1. The main thing was Ubuntu create RAID with 1.2 version 
metadata which should be fine, but it auto detects RAID setups wrong. So in 
installer I escaped to shell and manually built array with command:

mdadm --create --verbose /dev/md0 --level=1 --raid-devices=2
--metadata=0.90 /dev/sda1 /dev/sdb1

to force creation of 0.90 metadata which works properly. After that I
escaped shell and countinued setup from point where I just had to select
filesystem and mount point for RAID1 partition.

Can you please fix this bug? It really does not look serious in server
edition which should be installed with high security and availability in
mind.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1315344

Title:
  Grub install failed on disks with software RAID

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/grub-installer/+bug/1315344/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to