Public bug reported:

The Ubuntu Server team runs a series of tests against the LTS and
current development ISOs. On Trusty, one of the tests is to install a
minimal VM kernel by using the "linux-virtual" kernel via a preseed
entry as follows:

d-i base-installer/kernel/override-image string linux-virtual

On Trusty, the follow error is received:

Sep 14 22:40:43 base-installer: warning: Kernel override 'linux-virtual'
not present


And the only useable kernels are as follows:

Sep 14 22:40:43 base-installer: info: kernel linux-signed-generic-lts-xenial 
usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-generic-lts-xenial usable on 
em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-virtual-lts-xenial usable on 
em64t-p4
Sep 14 22:40:43 base-installer: info: kernel 
linux-signed-image-generic-lts-xenial usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-image-extra-4.4.0-31-generic 
usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-image-generic-lts-xenial 
usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-image-virtual-lts-xenial 
usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel 
linux-signed-image-4.4.0-31-generic usable on em64t-p4
Sep 14 22:40:43 base-installer: info: kernel linux-image-4.4.0-31-generic 
usable on em64t-p4


Which leads to the following kernels selected:

Sep 14 22:40:43 debconf: Adding [KERNELS] -> [linux-signed-generic-lts-
xenial,linux-generic-lts-xenial,linux-virtual-lts-xenial,linux-signed-
image-generic-lts-xenial,linux-image-extra-4.4.0-31-generic,linux-image-
generic-lts-xenial,linux-image-virtual-lts-xenial,linux-signed-
image-4.4.0-31-generic,linux-image-4.4.0-31-generic]


I would have expected the 'linux-virtual' meta package to exist and in this 
case possibly point to 'linux-virtual-lts-xenial'. This way my existing preseed 
would not need to be updated. Forgive me in advance if this is due to my lack 
of understanding of the LTS/HWE kernels, however as I stated I expected the 
linux-virtual package to continue to exist. This does work as expected on 
Yakkety and Xenial.

** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

** Attachment added: "syslog"
   https://bugs.launchpad.net/bugs/1625675/+attachment/4744424/+files/syslog

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1625675

Title:
  Trusty 'linux-virtual' kernel missing

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-meta/+bug/1625675/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to