@Mathieu - I've been doing some quick experiments with fallback.efi on
the ISO, and I'm not sure that alone will fix things.

The problem is that when fallback.efi is present, the installer isn't
launching. Instead, OVMF tries to PXE boot (which in my test environment
fails because I don't have the needed DHCP/TFTP setup), then OVMF falls
back to Shell>

I tried adding /EFI/BOOT/fallback.efi to both the latest Yakkety daily
ISO and the 16.04.1 ISO. In both cases, the installer doesn't boot, I
end up at Shell>

So although fallback.efi can work around the X64 Exception in the
Yakkety version of shim, it still doesn't give you a bootable installer.
If there's something obvious I'm missing, please let me know!

Also, do you have any idea why this faulty shim code path is taken when
running under QEMU + OVMF, but does not seem to be taken when running on
physical hardware?

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  yakkety: backport (or rebase to) fix eliminating a double-close in

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to