Did a local Test until launchpad builds and publishes:
1. create KVM capable xenial container
2. in the Xenial container create a guest
  KVM has default to wily (was one part of the old bug)
  $ KVM -M | grep wily
    pc-i440fx-wily       Ubuntu 15.04 PC (i440FX + PIIX, 1996) (default)
3. create a guest and check its machine type
  $ virsh dumpxml testme | xmllint --xpath "string(//domain/os/type/@machine)" -
    pc-i440fx-wily
4. upgrade to yakkety
   dpkg -l show  1:2.6.1+dfsg-0ubuntu3 now
5. check status of guest
  $ virsh list
     1     testme                         running
     Note: not killed on upgrade of the package as expected
  $ virsh dumpxml testme | xmllint --xpath "string(//domain/os/type/@machine)" -
     pc-i440fx-wilyroot
  $ virsh shutdown testme
  $ virsh start testme
     error: Failed to start domain testme
     error: internal error: process exited while connecting to monitor: 
2016-09-21T14:08:54.005107Z qemu-system-x86_64: -enable-kvm: unsupported 
machine type
     Use -machine help to list supported machines
6. insert locally built new version of qemu via local signed archive
    dpkg -l show 1:2.6.1+dfsg-0ubuntu4 now
7. check if it starts correctly now
  $ virsh start testme
  $ virsh list
     3     testme                         running
  $ virsh dumpxml testme | xmllint --xpath "string(//domain/os/type/@machine)" -
     pc-i440fx-wily

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1626070

Title:
  Removal of former release machine types breaks VMs using them

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/1626070/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to