** Changed in: webkit2gtk (Ubuntu)
     Assignee: (unassigned) => Jeremy Bicha (jbicha)

** Description changed:

  Impact
  ======
  webkit2gtk 2.14.1 is a new bugfix release in the stable 2.14 series
  
  https://webkitgtk.org/2016/10/11/webkitgtk2.14.1-released.html
  
- Fixes crash bug 1631682 in epiphany and evolution
+ * New upstream bugfix release (LP: #1632535)
+   + Fix multiple crash bugs including one affecting epiphany and evolution 
(LP: #1631682)
+ * debian/patches/install-minibrowser.patch:
+   + Drop patch, this has been merged upstream.
+ * debian/rules:
+   + Set -DENABLE_MINIBROWSER=ON.
+ * debian/libjavascriptcoregtk-4.0-bin.install:
+   + Install the jsc executable in /usr/bin.
  
  New webkit2gtk releases are often security updates. It would be good for
  the latest 2.14 to get more real testing in Ubuntu 16.10 before it gets
  backported to Ubuntu 16.04 LTS as a security update. There is no
  Security Advisory for 2.14 currently, but note that webkitgtk does not
  issue security advisories until the corresponding OS X Safari update is
  released.
  
  https://webkitgtk.org/security.html
  
  Test built on all regular PPA architectures:
  https://launchpad.net/~jbicha/+archive/ubuntu/arch/+packages
  
  (Please don't permanently add that PPA since I use it for packaging
  experiments)
  
  Test Case
  =========
  - Run epiphany-browser, evolution and yelp since those apps currently use 
webkitgtk's unstable DOM API
  - Run the ubiquity slideshow. Instructions for doing this without needing to 
run the installer are at
  
  https://bugs.launchpad.net/ubuntu/+source/webkit2gtk/+bug/1618956/comments/4
  
  Regression Potential
  ====================
  Low to Moderate. The diff is too large to be able to review very easily.
- A few months ago, a stable webkit2gtk update (2.12.4, fixed in 2.12.5) broke 
the ubiquity slideshow ( bug 1618956 ). This risk is mitigated because we are 
specifically testing for that.
+ A few months ago, a stable webkit2gtk update (2.12.4, fixed in 2.12.5) broke 
the ubiquity slideshow ( bug 1618956 ). This risk is mitigated because we are 
specifically testing for that now.
+ 
+ I have successfully run the test cases from my PPA.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1632535

Title:
  Update webkitgtk to 2.14.1 in yakkety

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webkit2gtk/+bug/1632535/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to