Hi. I never had the empty toolbar before Yakkety install today and I've
spent quite a bit of time re-discovering the solutions you list here.
I'm wrestling with the compiler errors from both emacs 25.1 and the 24.5
as distributed with Yakkety.

Can somebody explain how a package that does not build on Yakkety was
distributed with it? I thought that was impossible.

I've got the sources for the updates mentioned in #8 and am compiling. I
do confirm it does not crash at the same spot as the release version.
The new packages did compile.

However, the install hits some trouble. Do the errors below indicate
that some files have shifted between packages and so the install does
not easily upgrade?

$ sudo dpkg -i emacs24_24.5+1-7ubuntu1_amd64.deb 
emacs24-common_24.5+1-7ubuntu1_all.deb  emacs24-bin-common_24.5+1-7ub
untu1_amd64.deb  emacs24-el_24.5+1-7ubuntu1_all.deb
[sudo] password for pauljohn:
(Reading database ... 447471 files and directories currently installed.)
Preparing to unpack emacs24_24.5+1-7ubuntu1_amd64.deb ...
Remove auctex for emacs24
auctex/remove: Removing parsed (La)TeX macros for emacs24... done.
auctex/remove: Removing installed files for emacs24... done.
Remove cmake-data for emacs24
remove/cmake-data: Purging byte-compiled files for emacs24
Remove ess for emacs24
remove/ess: purging byte-compiled files for emacs24
Remove dictionaries-common for emacs24
remove/dictionaries-common: Purging byte-compiled files for flavour emacs24
Remove pylint for emacs24
remove/pylint: purging byte-compiled files for emacs24
Remove pspp for emacs24
remove/pspp: purging byte-compiled files for emacs24
Remove emacsen-common for emacs24
emacsen-common: Handling removal of emacsen flavor emacs24
Remove emacs-goodies-el for emacs24
remove/emacs-goodies-el: purging byte-compiled files for emacs24
Unpacking emacs24 (24.5+1-7ubuntu1) over (24.5+1-6ubuntu3) ...
dpkg: regarding emacs24-common_24.5+1-7ubuntu1_all.deb containing 
emacs24-common:
 emacs24-common conflicts with emacs24-el (<< 24.5+1-7ubuntu1)
  emacs24-el (version 24.5+1-6ubuntu3) is present and installed.

dpkg: error processing archive emacs24-common_24.5+1-7ubuntu1_all.deb 
(--install):
 conflicting packages - not installing emacs24-common
Preparing to unpack emacs24-bin-common_24.5+1-7ubuntu1_amd64.deb ...
Unpacking emacs24-bin-common (24.5+1-7ubuntu1) over (24.5+1-6ubuntu3) ...
Preparing to unpack emacs24-el_24.5+1-7ubuntu1_all.deb ...
Unpacking emacs24-el (24.5+1-7ubuntu1) over (24.5+1-6ubuntu3) ...
dpkg: dependency problems prevent configuration of emacs24-bin-common:
 emacs24-bin-common depends on emacs24-common (= 24.5+1-7ubuntu1); however:
  Version of emacs24-common on system is 24.5+1-6ubuntu3.

dpkg: error processing package emacs24-bin-common (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of emacs24-el:
 emacs24-el depends on emacs24-common (= 24.5+1-7ubuntu1); however:
  Version of emacs24-common on system is 24.5+1-6ubuntu3.

dpkg: error processing package emacs24-el (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of emacs24:
 emacs24 depends on emacs24-bin-common (= 24.5+1-7ubuntu1); however:
  Package emacs24-bin-common is not configured yet.

dpkg: error processing package emacs24 (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-6ubuntu4) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 emacs24-common_24.5+1-7ubuntu1_all.deb
 emacs24-bin-common
 emacs24-el
 emacs24

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1623585

Title:
  Toolbar is blank

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/emacs24/+bug/1623585/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to