Public bug reported:

This error appears to be 100% reproducible on arm64 builds targetting
yakkety (see e.g. https://launchpad.net/~ci-train-ppa-
service/+archive/ubuntu/2076/+build/11022370):

dh build-arch --parallel --with translations
   dh_testdir -a -O--parallel
   dh_update_autotools_config -a -O--parallel
   dh_auto_configure -a -O--parallel
        cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON 
-DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_SYSCONFDIR=/etc 
-DCMAKE_INSTALL_LOCALSTATEDIR=/var
-- The C compiler identification is GNU 6.2.0
-- The CXX compiler identification is GNU 6.2.0
-- Check for working C compiler: /usr/bin/aarch64-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/aarch64-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/aarch64-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/aarch64-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Could NOT find Lcov (missing:  LCOV_EXECUTABLE GENHTML_EXECUTABLE) 
-- Could NOT find gcovr (missing:  GCOVR_EXECUTABLE) 
CMake Error at src/Ubuntu/CMakeLists.txt:31 (message):
  Invalid chromium version: ''

It is fixed in the staging branch of webbrowser-app (original bug
report: bug #1599695), the fix needs to be backported to yakkety.

[Regression potential]
Low. Need to verify that the chromium version advertised in user agent 
overrides is still correct.

** Affects: webbrowser-app (Ubuntu)
     Importance: High
     Assignee: Olivier Tilloy (osomon)
         Status: In Progress

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1633439

Title:
  FTBFS on yakkety arm64: Invalid chromium version: ''

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1633439/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to