I am keen to help as much as I can, but I am new to this and not very good.
I tried as you suggested - some console messages and then a Problem in
libsane window which contained this:-
The problem cannot be reported:

This is not an official Ubuntu package. Please remove any third party
package and try again.

The console messages read:-
/usr/share/apport/apport-gtk:16: PyGIWarning: Wnck was imported without
specifying a version first. Use gi.require_version('Wnck', '3.0') before
import to ensure that the right version gets loaded.
  from gi.repository import GLib, Wnck, GdkX11, Gdk

(apport-gtk:3429): Gtk-WARNING **: Theme parsing error:
gtk-widgets.css:65:17: Theming engine 'unico' not found
Gtk-Message: GtkDialog mapped without a transient parent. This is
discouraged.

Remember, at this point I am trying your request against a fixed system
given that I have installed some experimental packages.

If I can help further then I will try.

DaveG


On 15 October 2016 at 13:01, Christopher M. Penalver <
christopher.m.penal...@gmail.com> wrote:

> Dave Goldsbrough, it will help immensely if you filed a new report with
> Ubuntu via a terminal:
> ubuntu-bug libsane
>
> Please feel free to subscribe me to it.
>
> For more on why this is helpful, please see
> https://wiki.ubuntu.com/ReportingBugs.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1526198
>
> Title:
>   simple-scan doesn't work with MG5350 anymore (wifi)
>
> Status in simple-scan package in Ubuntu:
>   Invalid
>
> Bug description:
>   Hi,
>   Was working very fine until I upgraded to Ubuntu 15.04 to 15.10
>
>   Ubuntu 15.10 64bits
>
>   $ simple-scan -d
>   [+0,00s] DEBUG: simple-scan.vala:674: Starting Simple Scan 3.18.1,
> PID=7498
>   [+0,00s] DEBUG: Connecting to session manager
>   [+0,05s] DEBUG: ui.vala:2018: Loading state from
> /home/user/.cache/simple-scan/state
>   [+0,05s] DEBUG: ui.vala:1986: Restoring window to 883x400 pixels
>   [+0,05s] DEBUG: autosave-manager.vala:64: Loading autosave information
>   [+0,05s] DEBUG: autosave-manager.vala:259: Waiting to autosave...
>   [+0,05s] CRITICAL: gtk_event_controller_reset: assertion
> 'GTK_IS_EVENT_CONTROLLER (controller)' failed
>   [+0,08s] DEBUG: scanner.vala:1446: sane_init () -> SANE_STATUS_GOOD
>   [+0,08s] DEBUG: scanner.vala:1452: SANE version 1.0.25
>   [+0,08s] DEBUG: scanner.vala:1513: Requesting redetection of scan devices
>   [+0,08s] DEBUG: scanner.vala:802: Processing request
>   [+0,15s] DEBUG: autosave-manager.vala:281: Autosaving book information
>   [+0,19s] DEBUG: ui.vala:2109: Saving state to
> /home/user/.cache/simple-scan/state
>   [+3,75s] DEBUG: simple-scan.vala:404: Requesting scan at 150 dpi from
> device '(null)'
>   [+3,75s] DEBUG: scanner.vala:1559: Scanner.scan ("(null)", dpi=150,
> scan_mode=ScanMode.GRAY, depth=2, type=ScanType.SINGLE, paper_width=0,
> paper_height=0, brightness=0, contrast=0)
>   [+4,34s] DEBUG: scanner.vala:338: sane_get_devices () -> SANE_STATUS_GOOD
>   [+4,34s] DEBUG: scanner.vala:350: Device: name="pixma:MG5300_192.168.1.83"
> vendor="CANON" model="Canon PIXMA MG5300" type="multi-function peripheral"
>   [+4,34s] DEBUG: scanner.vala:802: Processing request
>   [bjnp] udp_command: ERROR - no data received
>   [bjnp] bjnp_init_device_structure: Cannot read mac address, skipping
> this scanner
>   [+17,00s] DEBUG: scanner.vala:863: sane_open
> ("pixma:MG5300_192.168.1.83") -> SANE_STATUS_INVAL
>   [+17,00s] WARNING: scanner.vala:867: Unable to get open device: Invalid
> argument
>   [+17,10s] DEBUG: ui.vala:2109: Saving state to
> /home/user/.cache/simple-scan/state
>   [+82,44s] DEBUG: ui.vala:2109: Saving state to
> /home/user/.cache/simple-scan/state
>   [+125,63s] DEBUG: ui.vala:2109: Saving state to
> /home/user/.cache/simple-scan/state
>   [+130,72s] DEBUG: autosave-manager.vala:195: Deleting autosave records
>   [+130,72s] DEBUG: scanner.vala:1586: Stopping scan thread
>   [+130,72s] DEBUG: scanner.vala:802: Processing request
>   [+130,73s] DEBUG: scanner.vala:1597: sane_exit ()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/simple-scan/+
> bug/1526198/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1526198

Title:
  simple-scan doesn't work with MG5350 anymore (wifi)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1526198/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to