Public bug reported:

When returning from sleep, everything works except for network.

Here is what I see in /var/log/syslog :

Oct 15 12:40:16 XPS systemd[1]: Starting Network Manager Script Dispatcher 
Service...
Oct 15 12:40:16 XPS dbus[946]: [system] Successfully activated service 
'org.freedesktop.nm_dispatcher'
Oct 15 12:40:16 XPS systemd[1]: Started Network Manager Script Dispatcher 
Service.
Oct 15 12:40:16 XPS nm-dispatcher: req:1 'down' [wlan0]: new request (2 scripts)
Oct 15 12:40:16 XPS nm-dispatcher: req:1 'down' [wlan0]: start running ordered 
scripts...
Oct 15 12:40:16 XPS nm-dispatcher[5639]: 
/etc/network/if-post-down.d/ubuntu-fan: 29: 
/etc/network/if-post-down.d/ubuntu-fan: /usr/sbin/fanctl: not found
Oct 15 12:40:16 XPS nm-dispatcher[5639]: run-parts: 
/etc/network/if-post-down.d/ubuntu-fan exited with return code 127
Oct 15 12:40:16 XPS nm-dispatcher: req:1 'down' [wlan0], 
"/etc/NetworkManager/dispatcher.d/01ifupdown": complete: failed with Script 
'/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
Oct 15 12:40:16 XPS NetworkManager[954]: <info>  [1476528016.5196] device 
(wlan0): state change: disconnected -> unmanaged (reason 'sleeping') [30 10 37]
Oct 15 12:40:16 XPS wpa_supplicant[1147]: nl80211: deinit ifname=wlan0 
disabled_11b_rates=0
Oct 15 12:40:16 XPS NetworkManager[954]: <warn>  [1476528016.6003] dispatcher: 
(5) 01ifupdown failed (failed): Script 
'/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.

Perhaps this error : /usr/sbin/fanctl: not found is fatal to resume
network ?

Have you experienced the same ?

Only solution for the moment is to reboot.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: network-manager 1.2.4-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-25.27-generic 4.8.1
Uname: Linux 4.8.0-25-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Oct 15 23:22:22 2016
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-trusty-amd64-20140620-0
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2015-06-25 (478 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 
20140620-04:25
IpRoute:
 
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
SourcePackage: network-manager
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 
2016-10-13T06:48:12.364564
nmcli-dev:
 DEVICE  TYPE      STATE      DBUS-PATH                                  
CONNECTION  CON-UUID  CON-PATH 
 lo      loopback  unmanaged  /org/freedesktop/NetworkManager/Devices/1  --     
     --        --       
 wlan0   wifi      unmanaged  /org/freedesktop/NetworkManager/Devices/0  --     
     --        --
nmcli-nm:
 RUNNING  VERSION  STATE         STARTUP  CONNECTIVITY  NETWORKING  WIFI-HW  
WIFI     WWAN-HW  WWAN    
 running  1.2.4    disconnected  started  none          enabled     enabled  
enabled  enabled  enabled

** Affects: network-manager (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug yakkety

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1633775

Title:
  No network when waking up from sleep

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1633775/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to