Public bug reported:

[Description]
Rebuilding cinder and glance with python2.7.12 for trusty is resulting in kombu 
failures such as:

Traceback (most recent call last):
  ...
  File "/usr/lib/python2.7/dist-packages/kombu/utils/__init__.py", line 17, in 
<module>
    from uuid import UUID, uuid4 as _uuid4, _uuid_generate_random
ImportError: cannot import name _uuid_generate_random

See: http://qa.ubuntuwire.org/ftbfs/rebuilds/test-rebuild-20161216
-updates-python2712-trusty.html

This backports a patch from upstream kombu to fix the uuid shim in newer
Python versions. It is also backward compatible with the current version
of Python in trusty.

[Test Case]
Building cinder and glance will run unit tests that will fail with Python2.7.12 
without this patch.

[Regression Potential]
Low. The patch is cherry-picked from upstream.

** Affects: kombu (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1656333

Title:
  [SRU] Fix uuid shim in newer Python versions

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/kombu/+bug/1656333/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to