apport information

** Tags added: zesty

** Description changed:

  I have an Elantech Touchpad installed on my Lenovo Y700 laptop and I
  can't make it work properly by any means. I tried to switch between
  libinput and synaptics but this bug seems to affect any driver.
  
  Usually, after a system upgrade all works properly till the moment I
  plug in external mouse (Razer DeathAdder 3500DPI). After that touchpad
  detected as either PS/2 BYD or PS/2 generic mouse or sometimes PS/2
  Elantech touchpad.
  
  After some 5-6 reboots without plugging in external mouse the touchpad
  finally starts to detect it as ETPS/2 Elantech touchpad.
  
  Reloading psmouse module seems to cause no effect (or it does yet after
  a minute touchpad stops working for a moment and then switches to PS/2
  in xinput). Multitouch stops working as well as tapping with two
  fingers.
  
  I tried almost all the possible workarounds involving adding boot
  options, installing elantech driver fixes etc.
  
  Help is appreciated.
  
  The output of xinput as for now:
  
  $ xinput
  ⎡ Virtual core pointer                        id=2    [master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer                      id=4    [slave  pointer 
 (2)]
  ⎜   ↳ PS/2 BYD TouchPad                               id=14   [slave  pointer 
 (2)]
  
  lsinput
  /dev/input/event14
     bustype : BUS_I8042
     vendor  : 0x2
     product : 0x1
     version : 99
     name    : "PS/2 BYD TouchPad"
     phys    : "isa0060/serio1/input0"
     bits ev : EV_SYN EV_KEY EV_REL
  
  UPDATE:
  
  Seems that forcing the psmouse to detect the touchpad as elantech helps
  to fix problem temporarily. But it works only from time to time:
  
  $ sudo rmmod psmouse
  $ sudo modprobe psmouse force="elantech"
  --- 
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-08-27 (52 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
(20160719)
  Package: linux (not installed)
  Tags:  xenial
  Uname: Linux 4.6.0-040600-generic x86_64
  UnreportableReason: The running kernel is not an Ubuntu kernel
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
+ --- 
+ ApportVersion: 2.20.4-0ubuntu4
+ Architecture: amd64
+ AudioDevicesInUse:
+  USER        PID ACCESS COMMAND
+  /dev/snd/controlC0:  blobmasta   2054 F.... pulseaudio
+ CurrentDesktop: Unity:Unity7
+ DistroRelease: Ubuntu 17.04
+ InstallationDate: Installed on 2018-01-07 (3 days ago)
+ InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
+ MachineType: LENOVO 80NV
+ Package: linux (not installed)
+ ProcFB: 0 inteldrmfb
+ ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-42-generic.efi.signed 
root=UUID=e8b26b1d-8539-4186-b5d1-0b54182e3d56 ro quiet splash vt.handoff=7
+ ProcVersionSignature: Ubuntu 4.10.0-42.46-generic 4.10.17
+ RelatedPackageVersions:
+  linux-restricted-modules-4.10.0-42-generic N/A
+  linux-backports-modules-4.10.0-42-generic  N/A
+  linux-firmware                             1.164
+ Tags:  zesty
+ Uname: Linux 4.10.0-42-generic x86_64
+ UpgradeStatus: No upgrade log present (probably fresh install)
+ UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
+ _MarkForUpload: True
+ dmi.bios.date: 09/19/2016
+ dmi.bios.vendor: LENOVO
+ dmi.bios.version: CDCN53WW
+ dmi.board.asset.tag: NO Asset Tag
+ dmi.board.name: Allsparks 5A
+ dmi.board.vendor: LENOVO
+ dmi.board.version: SDK0J40688 WIN
+ dmi.chassis.asset.tag: NO Asset Tag
+ dmi.chassis.type: 10
+ dmi.chassis.vendor: LENOVO
+ dmi.chassis.version: Lenovo ideapad Y700-15ISK
+ dmi.modalias: 
dmi:bvnLENOVO:bvrCDCN53WW:bd09/19/2016:svnLENOVO:pn80NV:pvrLenovoideapadY700-15ISK:rvnLENOVO:rnAllsparks5A:rvrSDK0J40688WIN:cvnLENOVO:ct10:cvrLenovoideapadY700-15ISK:
+ dmi.product.name: 80NV
+ dmi.product.version: Lenovo ideapad Y700-15ISK
+ dmi.sys.vendor: LENOVO

** Attachment added: "AlsaInfo.txt"
   
https://bugs.launchpad.net/bugs/1634593/+attachment/5035228/+files/AlsaInfo.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1634593

Title:
  Elantech Touchpad detects as PS/2 BYD TouchPad or as a PS/2 generic
  mouse

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1634593/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to