Public bug reported:

When trying to start hgview 1.9.0-1.1 on Artful, it fails to start with
the following message:

Traceback (most recent call last):
  File "/usr/bin/hgview", line 38, in <module>
    main()
  File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 226, 
in main
    sys.exit(start(repo, opts, args, parser.error))
  File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 174, 
in start
    app = Application(repo, opts, args)
  File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/application.py", line 
54, in __init__
    super(HgViewQtApplication, self).__init__(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 84, in 
__init__
    self.choose_viewer()
  File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 108, 
in choose_viewer
    viewer = self.HgRepoViewer(self.repo)
  File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/hgrepoviewer.py", line 
106, in __init__
    self._repodate = self._getrepomtime()
  File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/hgrepoviewer.py", line 
623, in _getrepomtime
    for l in (self.repo.sjoin('lock'), self.repo.join('wlock')):

This appears to affect all repositories.
--- 
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
DistroRelease: Ubuntu 17.10
InstallationDate: Installed on 2015-06-04 (983 days ago)
InstallationMedia: Lubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
Package: hgview 1.9.0-1.1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Tags:  artful
Uname: Linux 4.13.0-32-generic x86_64
UpgradeStatus: Upgraded to artful on 2017-11-09 (94 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare scanner sudo
_MarkForUpload: True

** Affects: hgview (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-collected artful

** Tags added: apport-collected artful

** Description changed:

  When trying to start hgview 1.9.0-1.1 on Artful, it fails to start with
  the following message:
  
  Traceback (most recent call last):
    File "/usr/bin/hgview", line 38, in <module>
      main()
    File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 226, 
in main
      sys.exit(start(repo, opts, args, parser.error))
    File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 174, 
in start
      app = Application(repo, opts, args)
    File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/application.py", line 
54, in __init__
      super(HgViewQtApplication, self).__init__(*args, **kwargs)
    File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 84, 
in __init__
      self.choose_viewer()
    File "/usr/lib/python2.7/dist-packages/hgviewlib/application.py", line 108, 
in choose_viewer
      viewer = self.HgRepoViewer(self.repo)
    File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/hgrepoviewer.py", line 
106, in __init__
      self._repodate = self._getrepomtime()
    File "/usr/lib/python2.7/dist-packages/hgviewlib/qt4/hgrepoviewer.py", line 
623, in _getrepomtime
      for l in (self.repo.sjoin('lock'), self.repo.join('wlock')):
  
  This appears to affect all repositories.
+ --- 
+ ApportVersion: 2.20.7-0ubuntu3.7
+ Architecture: amd64
+ DistroRelease: Ubuntu 17.10
+ InstallationDate: Installed on 2015-06-04 (983 days ago)
+ InstallationMedia: Lubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
+ Package: hgview 1.9.0-1.1
+ PackageArchitecture: all
+ ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
+ Tags:  artful
+ Uname: Linux 4.13.0-32-generic x86_64
+ UpgradeStatus: Upgraded to artful on 2017-11-09 (94 days ago)
+ UserGroups: adm cdrom dip lpadmin plugdev sambashare scanner sudo
+ _MarkForUpload: True

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1748925

Title:
  hgview will not start

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/hgview/+bug/1748925/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to