Public bug reported:

Occurs with: B.02.17 on Ubuntu 16.04, and also other versions (don't
know which exactly, but affects every version I've tried this on over
the years).

Seems to affect the lshw program on other Linux distros too. I tried
reporting on, but it
didn't seem to work.


If there is a hybrid MBR present as well as a GPT, lshw reads the hybrid
MBR instead of the GPT. I find this odd, given that lshw can read and
understand GPT disks just fine.

Expected to happen:

lshw reports full disk partition information using the GPT, even when
there's a hybrid MBR present on the disk.

What actually happens:

lshw reports partial/potentially incorrect information using the hybrid
MBR, if one exists, even though there's a GPT will full information as

Do I need to provide any further information?


** Affects: lshw (Ubuntu)
     Importance: Undecided
         Status: New

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  Weird behaviour with hybrid MBRs

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to