Okay, a little code inspection leads to one of these two function calls
failing at line 3062:

                if (crtc == ref_crtc) {
                        if (drmmode_page_flip_target_absolute(pRADEONEnt,
                                                              drmmode_crtc,
                                                              fb->handle,
                                                              flip_flags,
                                                              drm_queue_seq,
                                                              target_msc) != 0)
                                goto flip_error;
                } else {
                        if (drmmode_page_flip_target_relative(pRADEONEnt,
                                                              drmmode_crtc,
                                                              fb->handle,
                                                              flip_flags,
                                                              drm_queue_seq, 0) 
!= 0)
                                goto flip_error;
                }

Next step is gdb attach and setting a break point.

Now, I'm *not* a video driver guru, so, at some point, I'll need
somebody that's in this code regularly to take a look.  Thanks.  (Or,
maybe I'll get luckly and find a simply error... ;-) )

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1750393

Title:
  Blank screen with only mouse pointer after mesa driver update; display
  does not switch to tty7 upon lightdm start; Xorg.0.log quickly grows

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati-hwe-16.04/+bug/1750393/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to