apport information

** Tags added: apport-collected

** Description changed:

  Hi,
  
  Applying the Spectre/Meltdown patched kernel (3.2.0-133-generic -
  precise ESM), it's not possible to boot my xen domUs anymore (dom0 is
  fine). It works fine with 3.2.0-131-generic and 3.13.0-141-generic (lts-
  trusty with Spectre/Meltdown mitigations).
  
  This is with xen 4.1.6.1-0ubuntu0.12.04.13
  
  xend.log below :
  
  [2018-02-22 10:56:03 1566] DEBUG (XendDomainInfo:103) 
XendDomainInfo.create(['vm', ['name', 'REDACTED'], ['memory', '6144'], 
['on_reboot', 'restart'], ['on_crash', 'destroy'], ['on_xend_start', 'ignore'], 
['on_xend_stop', 'ignore'], ['vcpus', '1'], ['oos', 1], ['image', ['linux', 
['kernel', '/vmlinuz'], ['ramdisk', '/initrd.img'], ['root', '/dev/xvda1 ro'], 
['videoram', 4], ['args', 'nogbpages console=hvc0 earlyprintk=xen nosplash'], 
['tsc_mode', 0], ['nomigrate', 0]]], ['s3_integrity', 1], ['device', ['vbd', 
['uname', 'phy:/dev/Ubuntu/REDACTED-disk'], ['dev', 'xvda1'], ['mode', 'w']]], 
['device', ['vbd', ['uname', 'phy:Ubuntu/REDACTED-swap'], ['dev', 'xvda2'], 
['mode', 'w']]], ['device', ['vif', ['ip', 'REDACTED'], ['mac', 
'02:00:5B:BD:5E:E2']]]])                                                        
                    
  [2018-02-22 10:56:03 1566] DEBUG (XendDomainInfo:2498) 
XendDomainInfo.constructDomain                                                  
                                                                                
                                                              
  [2018-02-22 10:56:03 1566] DEBUG (balloon:187) Balloon: 6291628 KiB free; 
need 16384; done.                                                               
                                                                                
                                           
  [2018-02-22 10:56:03 1566] DEBUG (XendDomain:476) Adding Domain: 2            
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (XendDomainInfo:2836) 
XendDomainInfo.initDomain: 2 256                                                
                                                                                
                                                              
  [2018-02-22 10:56:03 1566] DEBUG (XendDomainInfo:2863) 
_initDomain:shadow_memory=0x0, memory_static_max=0x180000000, 
memory_static_min=0x0.                                                          
                                                                                
  [2018-02-22 10:56:03 1566] INFO (image:182) buildDomain os=linux dom=2 
vcpus=1                                                                         
                                                                                
                                              
  [2018-02-22 10:56:03 1566] DEBUG (image:721) domid          = 2               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:722) memsize        = 6144            
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:723) image          = /vmlinuz        
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:724) store_evtchn   = 1               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:725) console_evtchn = 2               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:726) cmdline        = root=/dev/xvda1 
ro nogbpages console=hvc0 earlyprintk=xen nosplash                              
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:727) ramdisk        = /initrd.img     
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:728) vcpus          = 1               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:729) features       =                 
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:730) flags          = 0               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:03 1566] DEBUG (image:731) superpages     = 0               
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:04 1566] ERROR (XendDomainInfo:2927) 
XendDomainInfo.initDomain: exception occurred                                   
                                                                                
                                                              
  Traceback (most recent call last):                                            
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
2898, in _initDomain                                                            
                                                                                
                                        
      channel_details = self.image.createImage()                                
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/image.py", line 165, in 
createImage                                                                     
                                                                                
                                         
      return self.createDomain()                                                
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/image.py", line 184, in 
createDomain                                                                    
                                                                                
                                         
      result = self.buildDomain()                                               
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/image.py", line 1069, in 
buildDomain                                                                     
                                                                                
                                        
      rc = LinuxImageHandler.buildDomain(self)                                  
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/image.py", line 745, in 
buildDomain                                                                     
                                                                                
                                         
      superpages     = self.superpages)                                         
                                                                                
                                                                                
                                       
  Error: (1, 'Internal error', 'panic: xc_dom_boot.c:79: launch_vm: 
SETVCPUCONTEXT failed (rc=-1)')                                                 
                                                                                
                                                   
  [2018-02-22 10:56:04 1566] ERROR (XendDomainInfo:488) VM start failed         
                                                                                
                                                                                
                                       
  Traceback (most recent call last):                                            
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
474, in start                                                                   
                                                                                
                                        
      XendTask.log_progress(31, 60, self._initDomain)                           
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendTask.py", line 209, 
in log_progress                                                                 
                                                                                
                                         
      retval = func(*args, **kwds)                                              
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
2930, in _initDomain                                                            
                                                                                
                                        
      raise VmError(str(exn))                                                   
                                                                                
                                                                                
                                       
  VmError: (1, 'Internal error', 'panic: xc_dom_boot.c:79: launch_vm: 
SETVCPUCONTEXT failed (rc=-1)')                                                 
                                                                                
                                                 
  [2018-02-22 10:56:04 1566] DEBUG (XendDomainInfo:3071) 
XendDomainInfo.destroy: domid=2                                                 
                                                                                
                                                              
  [2018-02-22 10:56:05 1566] DEBUG (XendDomainInfo:2401) Destroying device 
model                                                                           
                                                                                
                                            
  [2018-02-22 10:56:05 1566] DEBUG (XendDomainInfo:2408) Releasing devices      
                                                                                
                                                                                
                                       
  [2018-02-22 10:56:05 1566] ERROR (XendDomainInfo:108) Domain construction 
failed                                                                          
                                                                                
                                           
  Traceback (most recent call last):                                            
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
106, in create                                                                  
                                                                                
                                        
      vm.start()                                                                
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
474, in start                                                                   
                                                                                
                                        
      XendTask.log_progress(31, 60, self._initDomain)                           
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendTask.py", line 209, 
in log_progress                                                                 
                                                                                
                                         
      retval = func(*args, **kwds)                                              
                                                                                
                                                                                
                                       
    File "/usr/lib/xen-4.1/bin/../lib/python/xen/xend/XendDomainInfo.py", line 
2930, in _initDomain                                                            
                                                                                
                                        
      raise VmError(str(exn))                                                   
                                                                                
                                                                                
                                       
  VmError: (1, 'Internal error', 'panic: xc_dom_boot.c:79: launch_vm: 
SETVCPUCONTEXT failed (rc=-1)')
+ --- 
+ AlsaDevices:
+  total 0
+  crw-rw---T 1 root audio 116,  1 Feb 22 11:07 seq
+  crw-rw---T 1 root audio 116, 33 Feb 22 11:07 timer
+ AplayDevices: aplay: device_list:252: no soundcards found...
+ ApportVersion: 2.0.1-0ubuntu17.16
+ Architecture: amd64
+ ArecordDevices: arecord: device_list:252: no soundcards found...
+ AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', 
'/dev/snd/timer'] failed with exit code 1:
+ CRDA: Error: [Errno 2] No such file or directory
+ DistroRelease: Ubuntu 12.04
+ HibernationDevice: RESUME=UUID=05139b2f-7521-4f7a-968b-cb0d2d69373b
+ MachineType: HP ProLiant DL385 G2
+ MarkForUpload: True
+ Package: linux (not installed)
+ PciMultimedia:
+  
+ ProcEnviron:
+  TERM=screen-256color
+  PATH=(custom, no user)
+  LANG=en_GB.UTF-8
+  SHELL=/bin/bash
+ ProcFB: 0 radeondrmfb
+ ProcKernelCmdLine: root=UUID=4ec9439d-26b9-43b0-a4f8-5be9e0473ba4 ro 
console=tty0 console=ttyS1,38400
+ ProcVersionSignature: Ubuntu 3.13.0-141.190~precise1-generic 3.13.11-ckt39
+ RelatedPackageVersions:
+  linux-restricted-modules-3.13.0-141-generic N/A
+  linux-backports-modules-3.13.0-141-generic  N/A
+  linux-firmware                              1.79.18
+ RfKill: Error: [Errno 2] No such file or directory
+ Tags:  precise
+ UdevLog: Error: [Errno 13] Permission denied: '/var/log/udev'
+ Uname: Linux 3.13.0-141-generic x86_64
+ UnreportableReason: This is not an official Ubuntu package. Please remove any 
third party package and try again.
+ UpgradeStatus: Upgraded to precise on 2015-04-07 (1051 days ago)
+ UserGroups: adm
+ dmi.bios.date: 05/29/2008
+ dmi.bios.vendor: HP
+ dmi.bios.version: A09
+ dmi.chassis.type: 23
+ dmi.chassis.vendor: HP
+ dmi.modalias: 
dmi:bvnHP:bvrA09:bd05/29/2008:svnHP:pnProLiantDL385G2:pvr:cvnHP:ct23:cvr:
+ dmi.product.name: ProLiant DL385 G2
+ dmi.sys.vendor: HP

** Attachment added: "AcpiTables.txt"
   
https://bugs.launchpad.net/bugs/1751028/+attachment/5060308/+files/AcpiTables.txt

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1751028

Title:
  impossible to start a xen domain on precise with the spectre/meltdown
  kernel

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1751028/+subscriptions

-- 
ubuntu-bugs mailing list
ubuntu-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to